axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ibrahim demir <ibrahimdem...@yahoo.com>
Subject Re: Problem about getting the response (Axis2)
Date Wed, 19 Nov 2008 13:41:56 GMT
Hi Amila;

I have also tried it in an other way. So my first element was errorString in WSDL. And I regenerted
the stub.
 In response I got errorString first. But there is no change.

Can there be a problem about namespaces. Is this response a valid one?

<tns:outBag xmlns:tns="urn:cs.com.tr/banking">
 <tns:errorString></tns:errorString>
 <tns:result>1</tns:result>
 </tns:outBag>

 
Also there are lots of entires on google. but no one has enough information. 

https://issues.apache.org/jira/browse/AXIS2-3259  in this one it tells about a jar.

But I do not use this jar on my client and there is no compilation problem...

I am very confused and can not find a way to fix it.

yours.



Ibrahim DEMIR
CyberSoft Yazilim Muh.
http://www.ibrahimdemir.org

     
           
     




________________________________
From: Amila Suriarachchi <amilasuriarachchi@gmail.com>
To: axis-user@ws.apache.org
Sent: Wednesday, November 19, 2008 2:38:19 PM
Subject: Re: Problem about getting the response (Axis2)

<xs:complexType name="OutBag">
                <xs:sequence>
                    <xs:element name="result" type="xsd:string"/>
                    <xs:element name="errorString" type="xsd:string"/>
                </xs:sequence>
            </xs:complexType>

your response sequence has changed.

thanks,
Amila.

On 11/19/08, ibrahim demir <ibrahimdemire@yahoo.com> wrote:
> Hi All;
>
> I am using Axis2 1.4.1 and Eclipse codegen wizard to generate the client
> codes from wsdl.
>
> And using these libraries while running the client code:
>     axiom-api-1.2.7.jar
>     axiom-impl-1.2.7.jar
>     axis2-kernel-1.4.1.jar
>     geronimo-stax-api_1.0_spec-1.0.1.jar
>     xercesImpl-2.8.1.jar
>     axis2-adb-1.4.1.jar
>     activation-1.1.jar
>
> Everthing is fine.
>
> But when I test the client , the request goes to server and the server
> generates the response. But when I want to process the response on the
> client side I got this error.
>
> org.apache.axis2.AxisFault: org.apache.axis2.databinding.ADBException:
> Unexpected subelement errorString
>     at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
>
> My wsdl is attached and the server response is this:
>
> <tns:outBag xmlns:tns="urn:cs.com.tr/banking">
> <tns:errorString></tns:errorString>
> <tns:result>1</tns:result>
> </tns:outBag>
>
> Your help is ver needed.
>
> Yours.
>
>  Ibrahim DEMIR
> CyberSoft Yazilim Muh.
> http://www.ibrahimdemir.org
>
>
>


-- 
Amila Suriarachchi
WSO2 Inc.
blog: http://amilachinthaka.blogspot.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


      
Mime
View raw message