axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomás Tormo <tto...@indenova.com>
Subject Problem with deserializer
Date Wed, 19 Nov 2008 12:48:42 GMT
Greetings

In order to use a service of a company, we have to develope a 
webservice. The data flow goes like this: we call their webservice, and 
once they process the data we send them, they call a webservice 
developed by us, according to their specifications. The complex objects 
that our webservice recieve as arguments, are the same that the ones we 
send to the company in the first webservice call. Therefore, we get 
those objects from the wsdl of the company webservice using wsdl2java.

The first webservice call (the one we do to the company) goes ok, but 
the problem comes when they have to call our webservice. Axis throws the 
following exception:

  <faultstring>org.xml.sax.SAXException: Deserializing parameter 'in0': 
could not find deserializer for type 
{java:org.etsi.uri.TS102204.v1_1_2.MobileUserType}MobileUser</faultstring>

I should say that, in my opinion,  the objects are not well created with 
wsdl2java ( I tried axis 1.2 and axis 1.4) because some of the complex 
objects are in inhereiting data from other objects, but when they have 
to do the super call, the arguments are disordered.... I had to edit 
each object and put the arguments in the correct order.

I though the problem was the namespace that was defined in the object , 
but i tried to put the same as I was recieving in the soap call for that 
object and it happened the same.

Could anybody give me some advise about where this error comes from? If 
you need any kind of information please ask for it.

Thank you very much.

-- 
Un saludo,

Tomás Tormo Franco

Indenova, S.L.
Tels.: +34 963 81 99 47  ext.519
http://www.indenova.com
mailto:ttormo@indenova.com  


Mime
View raw message