axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sagara Gunathunga" <sagara.gunathu...@gmail.com>
Subject [AXIS2] Generated WSDL error for HTTPS transport
Date Tue, 04 Nov 2008 13:40:18 GMT
Hi,
I manage to expose a web service with HTTPS support on JBoss , I followed
following  steeps ( server is already configured for SSL).

1.  Restrict transport protocols in axis2.xml file by using
<transport>https</transport> element.

2. Configure the  transportReceiver for the certificate

<transportReceiver name="https"
class="org.apache.axis2.transport.nhttp.HttpCoreNIOSSLListener">
    <parameter name="port" locked="false">9002</parameter>
    <parameter name="non-blocking" locked="false">true</parameter>
        <parameter name="keystore" locked="false">
            <KeyStore>
                <Location>.keystore</Location>
                <Type>JKS</Type>
                <Password>11111111</Password>
                <KeyPassword>11111111</KeyPassword>
            </KeyStore>
        </parameter>
        <parameter name="truststore" locked="false">
            <TrustStore>
                <Location>.keystore</Location>
                <Type>JKS</Type>
                <Password>11111111</Password>
            </TrustStore>
        </parameter>
        <parameter name="SSLVerifyClient">optional</parameter>
        <!--    supports optional|require or defaults to none -->
    </transportReceiver>

with these settings application deployed well but in WSDL endpoint  address
for  HTTPS  binding not generated correctly instead  of
"server:port/contextroot " it has "null" value . as a example  (
*PayfoneService
*is the service name )

<wsdl:port name="PayfoneServiceHttpsSoap12Endpoint"
binding="ns:PayfoneServiceSoap12Binding">
*          <soap12:address
location="nullPayfoneService.PayfoneServiceHttpsSoap12Endpoint"/>*
</wsdl:port>
<wsdl:port name="PayfoneServiceHttpsEndpoint"
binding="ns:PayfoneServiceHttpBinding">
*          <http:address
location="nullPayfoneService.PayfoneServiceHttpsEndpoint"/>*
</wsdl:port>

Is there any way to solve this problem ...?



Thanks ,

Sagara Gunathunga

Blog - ssagara.blogspot.com
Web - http://sagaras.awardspace.com/

Mime
View raw message