axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bai Shen" <baishen.li...@gmail.com>
Subject Re: Integrating Axis2 with Tomcat and Eclipse
Date Thu, 02 Oct 2008 14:16:39 GMT
I'm not sure where you got that install path.  I've never seen that in any
setup of Tomcat that I've done.

Anyways, I'm running Tomcat integrated into Eclipse along with Axis2.  So
the log files aren't in the normal spot.  I looked in the temp dir that
Eclipse created, and there were no log files there either.  The console
doesn't contain any reference to the AdminService.

So I'm not sure what the deal is.  The only thing I noticed out of place in
the console was this.

[ERROR] Unable to find config file.  Creating new servlet engine config
file: /WEB-INF/server-config.wsdd


On Wed, Oct 1, 2008 at 5:47 PM, Barry Alexander <Barry_Alexander@gap.com>wrote:

>  Can you take a look in your Tomcat logs directory for recent logs for any
> issues reported there.  Path should be [installDIr]\Apache Software
> Foundation\Tomcat 6.0\logs
>
>
>
> You should see [INFO] entry for whether your AdminService was/was not
> deployed
>
>
>
> *From:* Bai Shen [mailto:baishen.lists@gmail.com]
> *Sent:* Wednesday, October 01, 2008 1:45 PM
>
> *To:* axis-user@ws.apache.org
> *Subject:* Re: Integrating Axis2 with Tomcat and Eclipse
>
>
>
> Okay, that worked.  Thanks.
>
> However, I didn't see any way to enable AdminService.  Any ideas on that?
>
> On Wed, Oct 1, 2008 at 3:47 PM, Barry Alexander <Barry_Alexander@gap.com>
> wrote:
>
> <CCheck you axis2.xml for admin access to axis2, default is:
>
>
>
> * * <parameter name="*userName*">*admin*</parameter>
>
> * * <parameter name="*password*">*axis2*</parameter>
>
>
>
> Ch
>
>
>
> *From:* Bai Shen [mailto:baishen.lists@gmail.com]
> *Sent:* Wednesday, October 01, 2008 12:35 PM
> *To:* axis-user@ws.apache.org
> *Subject:* Re: Integrating Axis2 with Tomcat and Eclipse
>
>
>
> Okay, I started the tutorial in the first link.  I'm not sure what version
> of Axis2/eclipse it's for, but several of the screenshots/settings are
> different than mine.  Anyways, I managed to get to the equivalent of step
> 13.  I was able to start my tomcat instance.  When I hit next, it attempted
> to deploy my service to tomcat.  However, I got the following error.
>
> [ERROR] The service cannot be found for the endpoint reference (EPR)
> http://localhost:8080/Axis2_Test/services/AdminService
> org.apache.axis2.AxisFault: The service cannot be found for the endpoint
> reference (EPR) http://localhost:8080/Axis2_Test/services/AdminService
>
> I'm not sure what I need to do the enable the AdminService.  It's not
> listed in my running services.  However, when I looked on my tomcat in the
> Axis2_Test dir, there was an axis2-web folder.  I went into that and was
> able to list my services.  There's also an Administration link, but when I
> click on that, it wants a login/pass.  I'm not sure what to use as I don't
> recall setting any usr/pass for Axis2.
>
> TIA.
>
> On Mon, Sep 29, 2008 at 1:34 AM, Grimm, Markus <Grimm@juris.de> wrote:
>
> Hi,
>
> Axis2-setup is integrated in Eclispe WTP.
> Look at
>
> http://www.eclipse.org/webtools/community/tutorials/BottomUpAxis2WebServ
> ice/bu_tutorial.html<http://www.eclipse.org/webtools/community/tutorials/BottomUpAxis2WebService/bu_tutorial.html>
or
> http://www.eclipse.org/webtools/community/tutorials/TopDownAxis2WebServi
> ce/td_tutorial.html<http://www.eclipse.org/webtools/community/tutorials/TopDownAxis2WebService/td_tutorial.html>
>
> Thanks,
> Markus
>
>
>
> ________________________________
>
> Von: Bai Shen [mailto:baishen.lists@gmail.com]
> Gesendet: Sonntag, 28. September 2008 21:30
> An: axis-user@ws.apache.org
> Betreff: Integrating Axis2 with Tomcat and Eclipse
>
>
>
> I've been using Eclipse, Tomcat, and Axis for a while.  However, I'm
> working on automating my setup. Thanks to the helpful members of the
> Tomcat list, I have Tomcat integrated with Eclipse, so I can code and
> deploy easily.
>
> What I'm curious about is if there is a way to add Axis2 to the setup?
> I'm running Eclipse 3.4, Tomcat 6.0.18, and Axis2 1.4.1.
>
> TIA.
>
> Bai Shen
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
>
>
>

Mime
View raw message