axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomás Tormo <tto...@indenova.com>
Subject Re: *SPAM* RE: Problem verifying the signature with wss4j
Date Wed, 03 Sep 2008 14:10:30 GMT
Thank you very much for your answer, but i forgot to specify that i'm 
writing a client in java using wss4j and not WSE, and i don't have 
access to the server (anyway, i'm new in this field,  so maybe i haven't 
understood it well...)

Do you know how to do the same for wss4j in the client?

Thank you.

Martin Gainty escribió:
> <policies xmlns="http://schemas.microsoft.com/wse/2005/06/policy"><BR>
> <policy name="x509"><BR>
> assume the specified policy includes the directive
> messageProtectionOrder="SignBeforeEncrypt"
> <BR>
>
> http://erlend.oftedal.no/blog/?blogid=12
> <BR>
> Saludos<BR>
> Martin <BR>
> ______________________________________________
> Disclaimer and confidentiality note
> Everything in this e-mail and any attachments relates to the official 
> business of Sender. This transmission is of a confidential nature and 
> Sender does not endorse distribution to any party other than intended 
> recipient. Sender does not necessarily endorse content contained 
> within this transmission.
>
>
> > Date: Wed, 3 Sep 2008 14:30:40 +0200
> > From: ttormo@indenova.com
> > To: axis-user@ws.apache.org
> > Subject: Problem verifying the signature with wss4j
> >
> > Greetings
> >
> > I'm trying to write an webservice client wich uses signed SOAP
> > messages in order to communicate. For this, i'm using wss4j 1.5.3 with
> > axis 1.4. I've succesfully wrote the client code wich signs the message
> > and sends it to the server, but i'm getting the following error:
> >
> > WSDoAllReceiver: security processing failed; nested exception is:
> > org.apache.ws.security.WSSecurityException: The signature
> > verification failed (The provided certificate is invalid)
> >
> > As far as i know (by reading posts in the internet) this is caused
> > because the XML is modified after it is signed. I've tried to set the
> > disablePrettyXML to true and the enableNamespacePrefixOptimization to
> > false, but it didn't work...
> >
> > I've read in other posts that this could be caused by the default blank
> > namespaces added by Axis (when I checked the XML thanks to TCPMonitor,
> > i could see that the attributes of the sent objects had no namespace,
> > but the object itself had).
> >
> > Does anybody have any solution for this problem? Could be possible to
> > disable the default namespace in axis?
> >
> > Thank you very much
> >
> > --
> > Un saludo,
> >
> > Tomás Tormo Franco
> >
> > Indenova, S.L.
> > Tels.: +34 963 81 99 47 ext.519
> > http://www.indenova.com
> > mailto:ttormo@indenova.com
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
>
> ------------------------------------------------------------------------
> Get more out of the Web. Learn 10 hidden secrets of Windows Live. 
> Learn Now 
> <http://windowslive.com/connect/post/jamiethomson.spaces.live.com-Blog-cns%21550F681DAD532637%215295.entry?ocid=TXT_TAGLM_WL_getmore_092008>

-- 
Un saludo,

Tomás Tormo Franco

Indenova, S.L.
Tels.: +34 963 81 99 47  ext.519
http://www.indenova.com
mailto:ttormo@indenova.com  


Mime
View raw message