axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vidura Gamini Abhaya" <vidu...@gmail.com>
Subject Axis2 Build error
Date Thu, 07 Aug 2008 02:58:32 GMT
Hi,

I'm trying to build Axis2 1.4 from its source. I get this build error inside
modules/integration,

[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.apache.xbean:xbean-spring:jar:3.2-SNAPSHOT

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=org.apache.xbean
-DartifactId=xbean-spring -Dversion=3.2-SNAPSHOT -Dpackaging=jar
-Dfile=/path/to/file

  Alternatively, if you host your own repository you can deploy the file
there:
      mvn deploy:deploy-file -DgroupId=org.apache.xbean
-DartifactId=xbean-spring -Dversion=3.2-SNAPSHOT -Dpackaging=jar
-Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

  Path to dependency:
      1) org.apache.axis2:axis2-integration:jar:1.4
      2) org.apache.activemq:apache-activemq:jar:5.0.0
      3) org.apache.activemq:activemq-console:jar:5.0.0
      4) org.apache.xbean:xbean-spring:jar:3.2-SNAPSHOT

----------
1 required artifact is missing.

for artifact:
  org.apache.axis2:axis2-integration:jar:1.4

from the specified remote repositories:
  apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
  java.net (https://maven-repository.dev.java.net/nonav/repository/),
  eclipse-repo (http://repo1.maven.org/eclipse),
  tomcat-repository (http://tomcat.apache.org/dev/dist/m2-repository),
  central (http://repo1.maven.org/maven2),
  apache-ws-snapshots2 (http://ws.zones.apache.org/repository2)


[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 11 seconds
[INFO] Finished at: Thu Aug 07 12:57:34 EST 2008
[INFO] Final Memory: 19M/80M
[INFO]
------------------------------------------------------------------------


The required .jar doesn't seem to be in any of the repositories. I've
tried building this with Java 1.6 as well as 1.5. Is it the case or am I
doing something wrong here?

Thanks,

Vidura

Mime
View raw message