axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nandana Mihindukulasooriya" <nandana....@gmail.com>
Subject Re: Need immediate help on error found while running the policy samples on embedded Axis2 1.4 + Rampart 1.4
Date Tue, 19 Aug 2008 08:21:37 GMT
Can you see the policies in the WSDL of those samples ? Please uncomment

				  <wsp:Policy>
					<!--  <sp:HttpsToken RequireClientCertificate="false"/> -->
				  </wsp:Policy>

before you try sample 01.

thanks,
nandana

On Tue, Aug 19, 2008 at 1:12 PM, Shaun Clayton <kloxklax@gmail.com> wrote:

> Hi all,
>
> Can someone guide me to solve this issue?
>
> I have been trying to embed axis2 1.4 and Rampart 1.4 in an application
> server running JDK 1.4.
> I have tested all the basic rampart samples. It works great.
> But when I tested the rampart 1.4 policy samples (sample 1, sample 2 and
> sample 3), an exception is thrown at the server side as follows:
>
>
> 2008-08-19 14:34:07 ICT [ISP.0090.0008D] [HttpConnection-8082-2] DEBUG
> org.apache.axis2.engine.Phase  - [MessageContext:
> logID=urn:uuid:1734987DE7FDB1
> 86641219131247221] Checking post-conditions for phase "OperationInPhase"
>
> 2008-08-19 14:34:07 ICT [ISP.0090.0008D] [HttpConnection-8082-2] DEBUG
> org.apache.axis2.engine.AxisEngine  - MustUnderstand header not processed or
> re
> gistered as understood{
> http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security<http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd%7DSecurity>
>
> 2008-08-19 14:34:07 ICT [ISP.0090.0008D] [HttpConnection-8082-2] DEBUG
> org.apache.axis2.i18n.ProjectResourceBundle  -
> org.apache.axis2.i18n.resource::
> handleGetObject(mustunderstandfailed)
> *2008-08-19 14:34:07 ICT [ISP.0090.0009D]  Message not found in
> "com.wm.resources.WmPublicMsgBundle". 0=[HttpConnection-8082-2] ERROR
> org.apache.axis2.
> engine.AxisEngine  - Must Understand check failed for header **
> http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd
> *<http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd>
> * : Secur
> ity
>  1=org.apache.axis2.AxisFault: Must Understand check failed for header ***<http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.x>
> *
> http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.x<http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd>
> **sd : Security
> *        at
> org.apache.axis2.engine.AxisEngine.checkMustUnderstand(AxisEngine.java:102)
>         at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:166)
>         at
> org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:275)
>         at
> org.apache.axis2.transport.http.HTTPWorker.service(HTTPWorker.java:278)
>         at
> com.jebe.wm.axis2.listeners.ISHttpWorker.service(ISHttpWorker.java:19)
>         at
> org.apache.axis2.transport.http.server.AxisHttpService.doService(AxisHttpService.java:281)
>         at
> org.apache.axis2.transport.http.server.AxisHttpService.handleRequest(AxisHttpService.java:187)
>         at
> org.apache.axis2.transport.http.server.HttpServiceProcessor.run(HttpServiceProcessor.java:82)
>         at
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1061)
>         at
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:575)
>         at java.lang.Thread.run(Thread.java:595)
>
>
> Thanks,
>
> Shaun Clayton
>



-- 
Nandana Mihindukulasooriya
WSO2 inc.

http://nandana83.blogspot.com/
http://www.wso2.org

Mime
View raw message