axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From searl <se...@ittc.ku.edu>
Subject [AXIS2] v1.4 missing binding and endpoint from wsdl2java generated wsdl
Date Wed, 16 Jul 2008 16:03:31 GMT
Hi,

I have a service that causes axis2 v1.4 to produce the following message
when axis2
is trying to deploy the service:

2008-07-15 17:09:53,178 [main] INFO 
org.apache.axis2.deployment.repository.util.ArchiveReader  - Trouble
processing wsdl file :No endpoints found in the WSDL

This service is created using the wsdl2java utility. The wsdl output
by wsdl2java does not have a 'binding' section and it does not have an
endpoint in the
'service' section. NOTE that I'm using wsdl v2.0.

Is the omitted 'binding' and 'endpoint' portions of the wsdl2java produced
wsdl
normal behavior?


I've attached the original wsdl2 for the service:
ACE_UDDIMAintain.orig.wsdl2
The wsdl produced by wsdl2java: ACE_UDDIMaintain.wsdl
and the services.xml produced by wsdl2java: services.xml.

The following the portion of the ant build file I use to run
wsdl2java:

	    <java  classname="org.apache.axis2.wsdl.WSDL2Java" fork="true"
failonerror="true">
                        <classpath>
				<fileset dir="${ACESOA_LIBDIR}" includes="*.jar"/>
				<fileset dir="${AXIS2LIBDIR}" includes="*.jar"/>
              
                        </classpath>
			<arg line="-o ${CURRDIR}/${SRCTEMPDIR}" />
			<arg line="-uri ${CURRDIR}/resources/${ant.project.name}.wsdl2" />
			<arg line="-d adb" />
			<arg line="-s" />
			<arg line="-ss" />
			<arg line="-ssi" />
			<arg line="-sd" />
			<arg line="-g" />
			<arg line="-wv 2.0" />
		</java>



-- 
Leon S. Searl, Software Research Engineer
Information and Telecommunication Technology Center, University of Kansas
Nichols Hall, 2335 Irving Hill Road, Lawrence, KS 66045-7612
Ph: 785-864-7820     Fax: 785-864-0387
http://www.ittc.ku.edu
Mime
View raw message