axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robert lazarski" <robertlazar...@gmail.com>
Subject Re: Please help: Caused by: java.lang.Exception: Axis2 Can't find Spring's ApplicationContext
Date Fri, 02 May 2008 13:50:33 GMT
Well you seem to have a lot of problems! Let me try and help you with
the spring stuff...

The error you point to is an advanced use case, and while I'm
confident it works because I tested it, I suggest you try something
simpler. The link you point to, while old, never the less tries to
init spring without the help of a servlet container via axis2
lifecycle stuff.

What is far easier is configuring spring as most apps do - outside
even of axis2 - via web.xml .

http://ws.apache.org/axis2/1_4/spring.html

Try the "With a ServletContext" example . (the sublinks are broken in
the 1.4 spring docs, argh! ).

HTH,
Robert

On Fri, May 2, 2008 at 10:15 AM, Michael Bauer <codechimp@gmail.com> wrote:
>
> I am getting really desperate for help here.  Its possible that my emails
> are not making it to the group, but I hope someone can get me pointed in the
> right direction.
>
> I am trying to deploy a WS in Axis2 that was created using wsdl2java.sh.  I
> took the generated files, extended the Skeleton, and modified the
> services.xml to grab the Impl class from Spring.
>
> The end-goal is to have a web service that I can import using FlexBuilder
> 3's WS import function.  When I kicked off the process, however, FlexBuilder
> complained that the WSDL 2.0 file produced was not a valid WSDL.  Further
> digging showed that FlexBuilder doesn't seem to support WSDL 2.0, so I tried
> to follow the recommendation of the WSDL 1.1 page and set the
> useOriginalwsdl to false (it was set to true).  However, doing so leaves a
> nasty stack trace:
>
>
> 08:58:43,038 ERROR [STDERR] org.apache.axis2.deployment.DeploymentException:
> The following error occurred during schema generation: null
> 08:58:43,039 ERROR [STDERR]     at
> org.apache.axis2.deployment.ServiceGroupBuilder.populateServiceGroup(ServiceGroupBuilder.java:106)
> 08:58:43,039 ERROR [STDERR]     at
> org.apache.axis2.deployment.repository.util.ArchiveReader.buildServiceGroup(ArchiveReader.java:110)
> 08:58:43,039 ERROR [STDERR]     at
> org.apache.axis2.deployment.repository.util.ArchiveReader.processServiceGroup(ArchiveReader.java:179)
> 08:58:43,039 ERROR [STDERR]     at
> org.apache.axis2.deployment.ServiceDeployer.deploy(ServiceDeployer.java:81)
> 08:58:43,039 ERROR [STDERR]     at
> org.apache.axis2.deployment.repository.util.DeploymentFileData.deploy(DeploymentFileData.java:136)
>      ...
>
>
> Whats interesting is further below in the stack trace:
>      ...
> 08:58:43,081 ERROR [STDERR] Caused by: org.apache.axis2.AxisFault: Axis2
> Can't find Spring's ApplicationContext
> 08:58:43,081 ERROR [STDERR]     at
> org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
> 08:58:43,081 ERROR [STDERR]     at
> org.apache.axis2.extensions.spring.receivers.SpringAppContextAwareObjectSupplier.getServiceObject(SpringAppContextAwareObjectSupplier.java:63)
> 08:58:43,081 ERROR [STDERR]     ... 159 more
>
> Through some research on Google, I found an article suggesting this was a
> coding problem in Axis2:
> http://www.mail-archive.com/axis-dev@ws.apache.org/msg23055.html
>
> It says its been resolved, but I just updated my maven2 POMs to pull Axis2
> 1.4 (was using Axis2 1.3), and I still get the same problem.  I even removed
> all the 1.3 generated files and re-generated them all using Axis2 1.4
> version of wsdl2java.sh.  I am not quite sure I understand the bug report
> fully, nor how to fix it.
>
> I could really use some assistance here.
>
>
>
>
> Michael Bauer
> mbauer@codechimp.net
> http://www.codechimp.net
>
>
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message