axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Tan" <tanl...@gmail.com>
Subject Re: Problem with Axis sample test
Date Mon, 05 May 2008 19:03:09 GMT
Steve:

Great news !!!   I finally got the "stock" sample to work. You are
correct when you suggested that I should run the sample test at the
AXIS_HOME directory. It was not working before cause I got typo in the url.

Now, I can move on to play with SOAPMonitorService.

Thanks again for your help !!!

Ben


On 5/5/08, Benjamin Tan <tanl142@gmail.com> wrote:
>
> Steve:
>
> You are da man !!!   I have found a copy of "mail.jar" from SUN. I have
> solved the deployment error of the "getQuote" example.
>
> Now, I am working on solving the other test client issue. To answer your
> question, I ran the script from the directory where samples are installed
> ($AXIS_HOME/samples/stock). I tried to run the test script from $AXIS_HOME
> directory and got the same result.
>
> I guess, it is a good learning curve for me. Once I have a better
> understanding of how AXIS is being put together, I should be able to reslove
> this "Exception in thread "main" java.lang.NoClassDefFoundError: GetQuote"
> error.
>
> Thank you very much for your time and suggestion. Without your help, I
> don't think that I can resolve the deployment issue.
>
> Ben...
>
>
> On 5/2/08, Steve Hall <shall@starmountsystems.com> wrote:
> >
> > You can get the mail.jar from sun just google javamail download.
> >
> > As for the cfne exception, im not sure, the class comes pre-compiled,
> > are you running the example from the axis home directory?
> >
> >
> > Benjamin Tan wrote:
> >
> > > Steve:
> > >  I did run the happyaxis page. It comes up ok. Also, I was able to
> > > enable the SOAPMonitor link. Then, I was trying to test out the sample and
> > > see SOAPMonitor in action.
> > >  By the way, JAF 1.1.1. <http://1.1.1.> don't include mail.jar file.
> > > Do you know when I can download one ?
> > >  Finally, I am on resolving another sample issue. I was trying to
> > > execute the GetQuote that I have deployed and getting "class not found
> > > error".  Please see the following screenshot:
> > >  command line to run "GetQuote" sample:
> > > -------------------------------------------------------------------
> > > java -cp $AXISCLASSPATH samples.stock.GetQuote
> > > -lhttp://localhost:8088/axis/servlet -uuser1 -wpass1 XXX
> > > -----------------------------------and get not found error
> > > -------------------------------------------------------
> > > Exception in thread "main" java.lang.NoClassDefFoundError:
> > > samples/stock/GetQuote
> > >    On 5/2/08, *Steve Hall* <shall@starmountsystems.com <mailto:
> > > shall@starmountsystems.com>> wrote:
> > >
> > >    Ben,
> > >
> > >    Have you run the happyaxis page that comes as part of the axis web
> > >    app? Also, the MimeMultipart class is part of the JavaMail API and
> > >    is not in activation.jar but rather in mail.jar.
> > >
> > >    Also, if you are running the getStockQuote example, as you
> > >    mentioned earlier, then the service should work as attachments are
> > >    not used in this example. Have you tried  running the service?
> > >
> > >    Steve
> > >
> > >
> > >    Benjamin Tan wrote:
> > >
> > >        Steve:
> > >         I have download JAF version 1.1.1 from SUN. I have included
> > >        the "activation.jar" the classpath and run the deployment
> > >        script again. I am still get the same error. One thing that I
> > >        noticed is that the deployment still went through. I saw the
> > >        sample service was added to Tomcat configuration file:
> > >        "server-config.wsdd".
> > >         Any idea ?  I hope, I have done the installation correctly.
> > >         I have included the screenshot of the error message as follow:
> > >
> > >  -------------------------------------------------------------------------------------------
> > >        *AXISCLASSPATH --->*
> > >
> > >  /vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib/axis.jar:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib/commons-discovery.jar:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib/commons-logging.jar:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib/jaxrpc.jar:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib/saaj.jar:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib/log4j-1.2.8.jar:/irg3tier/tanl/tomcat/common/endorsed/xml-apis.jar:/irg3tier/tanl/tomcat/common/endorsed/xercesImpl.jar:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/bin/axis-1_4/lib:/vobs/EAS_APPLICATIONS/EAI/glue/Axis/jaf-1.1.1/*activation.jar
> > >        - Unable to find required classes
> > >        (javax.activation.DataHandler and
> > >        javax.mail.internet.MimeMultipart). Attachment support is
> > >        disabled.
> > >        *Processing file deploy.wsdd
> > >        <Admin>Done processing</Admin>
> > >
> > >
> > >         On 5/1/08, *Steve Hall* <shall@starmountsystems.com
> > >        <mailto:shall@starmountsystems.com>
> > >        <mailto:shall@starmountsystems.com
> > >        <mailto:shall@starmountsystems.com>>> wrote:
> > >
> > >           Benjamin,
> > >
> > >           It looks like you need to add the javabeans activation
> > >        framework
> > >           (JAF) jar aka activation.jar to your classpath. JAF deals
> > > with
> > >           mime types and is used for attachments. Note, it is my
> > >           understanding that JAF is only required when writing
> > >        services that
> > >           use soap with attachments.
> > >
> > >
> > > http://java.sun.com/javase/technologies/desktop/javabeans/jaf/downloads/index.html
> > >
> > >           Steve Hall
> > >
> > >
> > > ---------------------------------------------------------------------
> > >           To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > >        <mailto:axis-user-unsubscribe@ws.apache.org>
> > >           <mailto:axis-user-unsubscribe@ws.apache.org
> > >        <mailto:axis-user-unsubscribe@ws.apache.org>>
> > >           For additional commands, e-mail:
> > >        axis-user-help@ws.apache.org <mailto:
> > > axis-user-help@ws.apache.org>
> > >           <mailto:axis-user-help@ws.apache.org
> > >        <mailto:axis-user-help@ws.apache.org>>
> > >
> > >
> > >
> > >
> > >
> >
>

Mime
View raw message