axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hari Prasad" <hariha...@gmail.com>
Subject Re: Problem with engaging security module in Axis2 1.4 version
Date Thu, 08 May 2008 17:20:39 GMT
Hi Nandana,

Yes I have this class in the class path but what I found out is the
ModulePolicyExtension class belongs to
org.apache.axis2.wsdl.codegen.extension

But the error I am getting is for this class org*/*apache*/*axis2*/*modules*
/*ModulePolicyExtension
Some where the code is looking for
org.apache.axis2.modules.ModulePolicyExtension class

Any inputs?

Regards
Hari P

On 5/8/08, Nandana Mihindukulasooriya <nandana.cse@gmail.com> wrote:
>
> Hi Hari,
>     do you have axis2-codegen-1.4.jar in your classpath ? If not, please
> add this jar in to your classpath. This jar ships with Axis2 binary
> distribution under lib. Even if you download the war distribution or create
> the distribution using maven, it is there. But if you create the war using
> the ant task in binary distribution, that script explicitly excludes this
> jar. :( .
>
> thanks,
> nandana
>
>
>  On 5/8/08, Hari Prasad <harihamsa@gmail.com> wrote:
> >
> > Hi Nandana,
> >
> > Thanks for the tips on debugging. I debugged the code and found that the
> > faulty modules has this 'rampart' module in it.
> > The error is the following
> >
> > java
> > *.*lang*.*NoClassDefFoundError*:* org*/*apache*/*axis2*/*modules*/*
> > ModulePolicyExtension
> > Which axis2 jar contains this class? I searched in all jars but could
> > not find this class. I downloaded the axis2-1.4 binaries yesterday.
> > Regards
> > Hari P
> >
> >  On 5/8/08, Nandana Mihindukulasooriya <nandana.cse@gmail.com> wrote:
> > >
> > > Hi Hari,
> > >
> > >  There are no compilation errors but when I run the program , I get
> > > > the same error
> > > > "org.apache.axis2.AxisFault: The system is attempting to engage a
> > > > module that is not available: rampart"
> > > >
> > >
> > > The possible reason is Rampart might not have been deployed correctly.
> > > Did you add all dependency jars to your classpath ? And if you can debug,
> > > you can check ConfigurationContext ->
> > > axisConfiguration -> faultyModules to check the reason why it has
> > > actually failed to deploy.
> > >
> > > BTW, Are you using a custom axis2.xml ?
> > >
> > > thanks,
> > > nandana
> > >
> > >
> > > >
> > > > On 5/8/08, Nandana Mihindukulasooriya <nandana.cse@gmail.com> wrote:
> > > > >
> > > > > Hi Hari,
> > > > >
> > > > > > Not knowing what else needs to be done?. I tried using rampart
> > > > > > with 1.4 It didn't work. Does Rampart
> > > > > > supported with axis2 1.4?
> > > > > >
> > > > >
> > > > > Yes, you can download Rampart 1.4 RC2 here [1]. Configuration
> > > > > should be like this.
> > > > >
> > > > >     <module ref="rampart" />
> > > > >
> > > > >     <parameter name="OutflowSecurity">
> > > > >         <action>
> > > > >             <items>UsernameToken Timestamp</items>
> > > > >             <user>bob</user>
> > > > >
> > > > > <passwordCallbackClass>org.apache.rampart.samples.sample02.PWCBHandler</passwordCallbackClass>
> > > > >         </action>
> > > > >     </parameter>
> > > > >
> > > > > you can find the complete axis2.xml here [2]. You can go through
> > > > > the samples come with Rampart distribution to get a better understanding.
> > > > >
> > > > >
> > > > > [1] - http://people.apache.org/~nandana/rampart-1.4/RC2/dist/<http://people.apache.org/%7Enandana/rampart-1.4/RC2/dist/>
> > > > > [2] -
> > > > > http://svn.apache.org/repos/asf/webservices/rampart/trunk/java/modules/rampart-samples/basic/sample02/client.axis2.xml
> > > > >
> > > > >
> > > > > thanks,
> > > > > nandana
> > > > >
> > > > >
> > > >
> >
>
>
> --
> Nandana Mihindukulasooriya
> WSO2 inc.
>
> http://nandana83.blogspot.com/
> http://nandanasm.wordpress.com/
>

Mime
View raw message