axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michele Mazzucco <Michele.Mazzu...@ncl.ac.uk>
Subject Re: Axis2 1.4 not Thread safe (possible bug)
Date Fri, 23 May 2008 16:56:54 GMT
I can only see a NullPointerException.

Michele


On 23 May 2008, at 14:31, sultanat wrote:

>
> Please see one of the errors we got during multiple threaded  
> processing:
> The requests sent were valid SOAP xmls sent via AXIS client.
>
> org.apache.axis2.AxisFault
>         at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
>         at
> com.atx.tokenserver.token.TokenServiceMessageReceiverInOut.fromOM 
> (TokenServiceMessageReceiverInOut.java:149)
>         at
> com.atx.tokenserver.token.TokenServiceMessageReceiverInOut.invokeBusin 
> essLogic(TokenServiceMessageReceiverInOut.java:43)
>         at
> org.apache.axis2.receivers.AbstractInOutMessageReceiver.invokeBusiness 
> Logic(AbstractInOutMessageReceiver.java:40)
>         at
> org.apache.axis2.receivers.AbstractMessageReceiver.receive 
> (AbstractMessageReceiver.java:100)
>         at org.apache.axis2.engine.AxisEngine.receive 
> (AxisEngine.java:176)
>         at
> org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequ 
> est(HTTPTransportUtils.java:275)
>         at
> org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java: 
> 131)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java: 
> 709)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java: 
> 802)
>         at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter 
> (ApplicationFilterChain.java:237)
>         at
> org.apache.catalina.core.ApplicationFilterChain.doFilter 
> (ApplicationFilterChain.java:157)
>         at
> org.apache.catalina.core.StandardWrapperValve.invoke 
> (StandardWrapperValve.java:214)
>         at
> org.apache.catalina.core.StandardContextValve.invoke 
> (StandardContextValve.java:178)
>         at
> org.apache.catalina.core.StandardHostValve.invoke 
> (StandardHostValve.java:126)
>         at
> org.apache.catalina.valves.ErrorReportValve.invoke 
> (ErrorReportValve.java:105)
>         at
> org.apache.catalina.core.StandardEngineValve.invoke 
> (StandardEngineValve.java:107)
>         at
> org.apache.catalina.connector.CoyoteAdapter.service 
> (CoyoteAdapter.java:148)
>         at
> org.apache.coyote.http11.Http11Processor.process 
> (Http11Processor.java:825)
>         at
> org.apache.coyote.http11.Http11Protocol 
> $Http11ConnectionHandler.processConnection(Http11Protocol.java:731)
>         at
> org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket 
> (PoolTcpEndpoint.java:526)
>         at
> org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt 
> (LeaderFollowerWorkerThread.java:80)
>         at
> org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run 
> (ThreadPool.java:684)
>         at java.lang.Thread.run(Thread.java:595)
> Caused by: java.lang.NullPointerException
>         at
> org.apache.axis2.databinding.utils.ConverterUtil.convertToString 
> (ConverterUtil.java:337)
>         at
> com.atx.tokenserver.token.xsd.DealerCode_type1.setDealerCode_type0 
> (DealerCode_type1.java:59)
>         at
> com.atx.tokenserver.token.xsd.DealerCode_type1$Factory.parse 
> (DealerCode_type1.java:417)
>         at
> com.atx.tokenserver.token.xsd.NewTokenRequest$Factory.parse 
> (NewTokenRequest.java:525)
>         at
> com.atx.tokenserver.token.TokenServiceMessageReceiverInOut.fromOM 
> (TokenServiceMessageReceiverInOut.java:136)
>         ... 22 more
>
>
> Michele Mazzucco-2 wrote:
>>
>> Please post more information (stack trace, etc.)
>>
>>
>> Michele
>>
>>
>> On 22 May 2008, at 23:24, sultanat wrote:
>>
>>>
>>>
>>> People,
>>> I created a web service using Axis2 1.4 and was accessing it with
>>> multiple
>>> Threads. It appears that
>>> the SOAP xml during parsing was getting corrupt and throwing all
>>> kinds of
>>> exceptons like
>>> invalid XML, expecting some other element etc...
>>>
>>> I tried the same test with same web service using Axis2 1.3 but I
>>> did not
>>> get any of the errors mentioned above.
>>> Is there anything which I am missing or is this a bug in Axis2 1.4 ?
>>> -- 
>>> View this message in context: http://www.nabble.com/Axis2-1.4-not-
>>> Thread-safe-%28possible-bug%29-tp17414803p17414803.html
>>> Sent from the Axis - User mailing list archive at Nabble.com.
>>>
>>>
>>> -------------------------------------------------------------------- 
>>> -
>>> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>>> For additional commands, e-mail: axis-user-help@ws.apache.org
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-user-help@ws.apache.org
>>
>>
>>
>
> -- 
> View this message in context: http://www.nabble.com/Axis2-1.4-not- 
> Thread-safe-%28possible-bug%29-tp17414803p17425676.html
> Sent from the Axis - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message