axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Smithian" <joe.smith...@gmail.com>
Subject Problems with Axis2 1.4
Date Tue, 13 May 2008 16:14:32 GMT
Hi all

I just downloaded and installed AXIS2-1.4 today. I tried wsdl2java and I was
pleased that some bugs such as "unexpected token: staticabstract" have been
fixed. Many thanks to the Axis2 development team. I experienced the
following problems:

====== 1- wsdl2java errors ==========

1- When I tried to generate the client stub, I got the following errors from
WSDL2java which are the same problems in axis2-1.3:

  Retrieving schema at 'http://www.w3.org/2001/xml.xsd', relative to
'file:/C:/wsdl/myService.wsdl'.
- Type {urn:oasis:names:tc:SAML:1.0:assertion}SubjectConfirmationData
missing!
- Type {urn:oasis:names:tc:SAML:1.0:assertion}AttributeValue missing!
- Could not find any schema type associated with the Element
'{urn:oasis:names:tc:dss:1.0:core:schema}ReturnVerificationTimeInfo'
- Could not find any schema type associated with the Element
'{urn:oasis:names:tc:dss:1.0:core:schema}ReturnSigningTimeInfo'
- Could not find any schema type associated with the Element
'{urn:oasis:names:tc:dss:1.0:core:schema}UseVerificationTime'
- Could not find any schema type associated with the Element
'{urn:oasis:names:tc:dss:1.0:core:schema}ReturnProcessingDetails'
- Could not find any schema type associated with the Element
'{urn:oasis:names:tc:dss:1.0:core:schema}ReturnSignerIdentity'

 Any comments? workaround?

=== 2. build errors ===

In spite of the above error client stub code was generated and I tested it
with my client application (which has been developed based on axis-2 1.3). I
got the following build errors. I fixed them by modifying the generated stub
as I've shown bellow:

       compile.src:
    [javac] Compiling 11 source files to C:\client1.4\build\classes

    ==== Build ERROR 1 ====
    [javac] C:\client1.4\src\myServiceStub.java:36878:
setAttributeValue(org.apache.axiom.om.OMElement[]) in
myServiceStub.AttributeType cannot be applied to (java.lang.Object[])
    [javac]      object.setAttributeValue(list1.toArray());
   *********************************************
    Fixed by adding a cast: object.setAttributeValue(
(org.apache.axiom.om.OMElement[])
list1.toArray());

***************************************************************************
   ===== Build ERROR 2 ===
    [javac] C:\Client1.4\src\myServiceStub.java:47171:
setSubjectConfirmationData(org.apache.axiom.om.OMElement) in
myServiceStub.SubjectConfirmationType cannot be applied to
(java.lang.Object)
    [javac]
object.setSubjectConfirmationData(org.apache.axis2.databinding.utils.ConverterUtil.getAnyTypeObject(reader,ExtensionMapper.class));

    [javac]
    ***************************************
    Fixed by adding a cast:   object.setSubjectConfirmationData(
(org.apache.axiom.om.OMElement)
org.apache.axis2.databinding.utils.ConverterUtil.getAnyTypeObject(reader,
ExtensionMapper.class));
********************************************************************************

I also had to change some class names in my client application because their
names have been changed in the generated stub.


After those changes I ran my client application and tested some SOAP
operations without problem and it can get services from my server. I am
going to do more tests and let you know if I see any problem. The server is
still using Axis2-1.3, I'll upgrade that to 1.4 later on.

Many thanks again to the Axis2 development team for their great job!

Regards

Joe

Mime
View raw message