axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alvarez-Blanes, Gian A" <gian.a.alvarez-bla...@lmco.com>
Subject RE: Error while using Axis2 Code Generator Plugin for Eclipse
Date Fri, 09 May 2008 19:18:27 GMT
Hi,

That is exactly what I had. I should work if you upgrade to JRE 6. :)


Gian A. Alvarez-Blanes 


-----Original Message-----
From: Tom Seelbach [mailto:tom.seelbach@gmail.com] 
Sent: Friday, May 09, 2008 3:17 PM
To: axis-user@ws.apache.org
Subject: RE: Error while using Axis2 Code Generator Plugin for Eclipse

Shawn, Gian,
Glad its working for you.  Too bad it doesn't work for me :)   

I'm using jre5, I  will try JRE 6 next...

  I added backport jar, and get past that exception.   Now I have this
one:

java.lang.NoClassDefFoundError: javax.xml.stream.XMLStreamException
        ...
        at 
org.apache.axis2.context.ConfigurationContextFactory.createBasicConfigur
ationContext(ConfigurationContextFactory.java:315)
        at 
org.apache.axis2.context.ConfigurationContextFactory.createDefaultConfig
urationContext(ConfigurationContextFactory.java:304)
        at 
org.apache.ws.java2wsdl.Java2WSDLBuilder.<init>(Java2WSDLBuilder.java:10
1)
        at 
org.apache.ws.java2wsdl.Java2WSDLCodegenEngine.<init>(Java2WSDLCodegenEn
gine.java:51)
        at 
org.apache.axis2.tool.codegen.eclipse.CodeGenWizard$2.execute(CodeGenWiz
ard.java:434)
        ...
        at 
org.apache.axis2.tool.codegen.eclipse.CodeGenWizard.doFinishJava2WSDL(Co
deGenWizard.java:449)
       
I see the XMLStreamException in  geronimo-stax-api_1.0_spec-1.0.1.jar.  
I added it, and updated the plugin.xml, and deleted

.workspace/.metadata/.plugins/Axis2_Codegen_Wizard -  but still get the
same error.



-Tom



-------- Original Message --------
Subject: 	RE: Error while using Axis2 Code Generator Plugin for
Eclipse
Date: 	Fri, 09 May 2008 14:15:32 -0400
From: 	Alvarez-Blanes, Gian A <gian.a.alvarez-blanes@lmco.com>
Reply-To: 	axis-user@ws.apache.org
To: 	axis-user@ws.apache.org
References: 
<79E4059BC98EAF48BBE42FCF392DAA520B5B693F@emss09m07.us.lmco.com> 
<48245888.8040304@gmail.com> 
<79E4059BC98EAF48BBE42FCF392DAA520B5B6941@emss09m07.us.lmco.com> 
<482474AF.5010607@gmail.com>



Thanks for all the help! I was able to get it working.  I was using JRE 
5. I switched to JRE6 and it seems to be working now.



Gian A. Alvarez-Blanes

 

 

-----Original Message-----
From: Shawn Talbot [mailto:giltron@gmail.com]
Sent: Friday, May 09, 2008 11:59 AM
To: axis-user@ws.apache.org
Subject: Re: Error while using Axis2 Code Generator Plugin for Eclipse

 

I am running Eclipse 3.4-m6 JEE version, Java 6

The only plugins I have installed (besides the axis codegen and service

archiver) are the subversive SVN plugins (Subversive SVN connectors, SVN

team provider, JavaHL).

 

Also to test, I downloaded a clean version of Eclipse 3.3 EE  (not extra

plugins) and started  a new workspace

(eclipse-jee-europa-winter-win32.zip with Java 6).  That also worked for
me.

 

Can you try using a new workspace and see if same error still occur?

 

Again, all I did was copy backport-util-concurrent-3.1.jar to

eclipse\plugins\Axis2_Codegen_Wizard_1.3.0\lib and add the library entry

in the plugin.xml file

 

Have you tried to start eclipse in debug mode and see what is output to

the console when the error occurs?

 

Hopefully you can get it going.

 

Thanks,

Shawn

 

Alvarez-Blanes, Gian A wrote:

>  Hi Shawn,

> 

>  I tried it yesterday and I just tried it again (since I had not
deleted

>  the plugin reference). It still didn't work. What version of eclipse
are

>  you using and what plugins do you have installed? I want to try it
with

>  a similar configuration and see if I can get it to work.

> 

>  I'm currently using 3.3 JEE version. I don't have anything else.

> 

>  Thanks,

> 

>  Gian A. Alvarez-Blanes

> 

> 

>  -----Original Message-----

>  From: Shawn Talbot [mailto:giltron@gmail.com]

>  Sent: Friday, May 09, 2008 9:59 AM

>  To: axis-user@ws.apache.org

>  Subject: Re: Error while using Axis2 Code Generator Plugin for
Eclipse

> 

>  Hello,

> 

>  I was the one with that issue.

>  Not sure if you did this too but have you also put the following:

>  <library name="lib/backport-util-concurrent-3.1.jar">

>  <export name="*"/>

>  </library>

> 

>  in the plugin.xml file?

> 

>  I also did that, though I am not sure if that was required.

> 

>  Also try to , delete the the reference to the plugin in your
workspace:

>  ..workspace/.metadata/.plugins/Axis2_Codegen_Wizard

> 

> 

>  Thanks,

>  Shawn

> 

>  Alvarez-Blanes, Gian A wrote:

>  

> > Hi,

> > 

> > I've been trying to get the code generator plugin to work since

> > yesterday with no luck. The problem is that when I click finish at
the

> >    

> 

>  

> > end of the wizard I get a

> > "java.lang.reflect.InvocationTargetException" pop up message. I

> > noticed that somebody in the mailing lis already posted this problem

> > and he was told to put the backport-util-concurrent-3.1.jar in the
lib

> >    

> 

>  

> > folder of the plugin. This didn't work for me.

> > 

> > I've tried it with Eclipse 3.3 and 3.2.2 with no luck. Is there

> > anything else that may fix this problem?

> > 

> > Thank you,

> > 

> > **Gian A. Alvarez-Blanes**

> > 

> >    

> 

> 

>  ---------------------------------------------------------------------

>  To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org

>  For additional commands, e-mail: axis-user-help@ws.apache.org

> 

> 

>  ---------------------------------------------------------------------

>  To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org

>  For additional commands, e-mail: axis-user-help@ws.apache.org

> 

> 

>  

 


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message