axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <joern.albin...@gmx.de>
Subject AW: REST with Axis 2
Date Tue, 20 May 2008 06:01:51 GMT
Hello Thilina,

Thank you for responding. 

The first one gives me this result:
http://yourmachine:port/axis2/services/customerservice/getCustomer?id=foo

- <ns:getCustomerResponse xmlns:ns="http://ws.apache.org/axis2">
  <ns:return xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:nil="true" /> 
  </ns:getCustomerResponse>


I think that works, but the Server delivers an empty result.  


And here I can't found a WSDL Data :
http://yourmachine:port/axis2/services/customerservice?wsdl


If I send data without SOAP I can reach the Endpoint. I get a response from
the server, but the data I'm sending don't be able to get in. 
There are no data. This is the request regarding with SOAP Monitor:  

<?xml version='1.0' encoding='utf-8'?>
<soapenv:Envelope xmlns:soapenv="http://www.w3.org/2003/05/soap-envelope">
  <soapenv:Body>
    <axis2ns69:getCustomer xmlns:axis2ns69="http://ws.apache.org/axis2" />
  </soapenv:Body>
</soapenv:Envelope>

It's empty..

So what can I do?

Thanks
Jörn



Are you trying this by typing
http://yourmachine:port/axis2/services/customerservice/getCustomer?id=foo
in the browser or programatically... If it's the later, what do you get when
you type that in the browser? Normally I experience this working directly
from the browser without doing any configuration changes.

Can you see the service wsdl in the following location..
http://yourmachine:port/axis2/services/customerservice?wsdl

thanks,
Thilina

On Sun, May 18, 2008 at 2:04 PM,  <joern.albinger@gmx.de> wrote:
> Hello together,
>
> I have the problem, that I can not send HTTP requests without SOAP to 
> my
> Axis2 Server.
>
> Im my "axis2.xml" I have configured the following:
>
>     <parameter name="enableRESTInAxis2MainServlet" >true</parameter>
>     <parameter name="disableSeparateEndpointForREST">true</parameter>
>     <parameter name="disableREST">false</parameter>
>
> It's for getting REST and SOAP at the same Endpoint.
>
> Now I have a simple method like this :
>
>
>
> public
> String getCustomer(String id){
>
> return id; }
>
>
> And this is the error returning from from the server:  What does that
means?
>
> org.apache.axis2.AxisFault: The service cannot be found for the 
> endpoint reference (EPR) /axis2/services/customerservice/getCustomer 
> at
> org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhas
> e.java:62) at org.apache.axis2.engine.Phase.invoke(Phase.java:308) at
> org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:212) at
> org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:132) at
> org.apache.axis2.transport.http.util.RESTUtil.invokeAxisEngine(RESTUti
> l.java:125)
> at
> org.apache.axis2.transport.http.util.RESTUtil.processXMLRequest(RESTUt
> il.java:78)
> at
> org.apache.axis2.transport.http.AxisServlet$RestRequestProcessor.proce
> ssXMLRequest(AxisServlet.java:788)
> at 
> org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:19
> 3) at javax.servlet.http.HttpServlet.service(HttpServlet.java:710) at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:803) at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appli
> cationFilterChain.java:290)
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFi
> lterChain.java:206)
> at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperVa
> lve.java:233)
> at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextVa
> lve.java:175)
> at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.ja
> va:128)
> at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.ja
> va:102)
> at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValv
> e.java:109)
> at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java
> :263)
> at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:
> 844)
> at
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proces
> s(Http11Protocol.java:584) at 
> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447
> ) at java.lang.Thread.run(Thread.java:619)
>
>
>
> Please, help me . It is very urgent for me to get started with REST ...
>
> Thanks a lot.
>
> Jörn
>
>
>
>
>
>



--
Thilina Gunarathne - http://thilinag.blogspot.com


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message