axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thilina Gunarathne" <cset...@gmail.com>
Subject Re: Swa webservice behave different in tomcat web app and axis2 standalone server.
Date Fri, 18 Apr 2008 18:57:17 GMT
Oh..Yeah... SOAPMonitor eats up the attachments.. It's always good to use
the TCPmon when testing attachments.. But even tcpmon chokes when using
large attachments, so make sure to use smaller attachments for testing...

~Thilina

On Fri, Apr 18, 2008 at 1:08 PM, Jinyuan Zhou <zhou.jinyuan@gmail.com>
wrote:

> Thanks Thilina,
> I used a new axi2-war. It worked. The only differences I can remember for
> myprevious  aix2 web app is that I configured the soap mionitor on and
> enabled the SwA in the axis2.xml. With TCPMon, I don't need SOAPMonitor. My
> be thats the reason axis2 1.3 does not contain a soapmonitor jar file.
> Regards,
> Jack
>
> On Wed, Apr 16, 2008 at 10:45 PM, Jinyuan Zhou <zhou.jinyuan@gmail.com>
> wrote:
>
> > Thanks for you time,
> > I will try to that again and post my result when i am done.
> > Jack
> >
> > On Wed, Apr 16, 2008 at 1:15 PM, Thilina Gunarathne <csethil@gmail.com>
> > wrote:
> >
> > > Hi,
> > > IIRC I tested that tutorial code with tomcat... I'm guessing something
> > > is going wrong in your system... Let's try to figure it out exactly..
> > >
> > > > The client side
> > > > was't able to find the attachment althought the correct envelop was
> > > > arrived..
> > > Did you mean you got the correct soap message together with the
> > > attachment from the server?? Can you capture a message snapshot using
> > > tcpmon (http://ws.apache.org/commons/tcpmon) and see whether you have
> > > the MIME part for the attachment.. It would be great if you can post
> > > it here..
> > >
> > > thanks,
> > > Thilina
> > >
> > > > I am using axis 2-1.3. My own arr has the similar behavior.  It
> > > > seems that the all samples and tutorial sare based on Stand alone
> > > server, I
> > > > just want see any one had the simliar experiences to deploy an aar
> > > into
> > > > tomcat and was able to include an attachment in the response message
> > > to
> > > > client.
> > > >  Thanks,
> > > > Jack
> > > >
> > > >
> > > > On Wed, Apr 16, 2008 at 7:39 AM, Thilina Gunarathne <
> > > csethil@gmail.com>
> > > > wrote:
> > > > > Hi,
> > > > > Just a quick reply...
> > > > > The sample used in the following tutorial is based on Tomcat
> > > deployment..
> > > > > Downloading a Binary File from a Web Service using Axis2 and SOAP
> > > with
> > > > Attachments - http://wso2.org/library/1675
> > > > >
> > > > > Also are you using the same axis2 version in both cases..
> > > > > thanks,
> > > > > Thilina
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > On 4/16/08, Jinyuan Zhou <zhou.jinyuan@gmail.com> wrote:
> > > > > >
> > > > > > Thank Thilina,
> > > > > > There are no error message. The usual soap request/response
goes
> > > well.
> > > > > > I also tried to deploy the one  arr file from a tutorial. Same
> > > thing
> > > > happend.
> > > > > > I just don't get it. I have build aar file using the standalone
> > > server's
> > > > lib. I'll try to build uisng the jar in WEB_INF/lib. See it will
> > > work.   I
> > > > wonder if DataHandler classes are different?   It looks like all
> > > examples
> > > > and tutorials are based on stand alone server.
> > > > > > Regards,
> > > > > > Jack
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Tue, Apr 15, 2008 at 8:20 PM, Thilina Gunarathne <
> > > csethil@gmail.com>
> > > > wrote:
> > > > > >
> > > > > > > Hi,
> > > > > > > Can you let us know more information, like any error messages,
> > > message
> > > > traces...
> > > > > > >
> > > > > > > thanks,
> > > > > > > Thilina
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > On Tue, Apr 15, 2008 at 8:58 PM, Jinyuan Zhou <
> > > zhou.jinyuan@gmail.com>
> > > > wrote:
> > > > > > >
> > > > > > > > Hi,
> > > > > > > > I have developed a websevice that will include an
attachment
> > > to the
> > > > client. It worked in the standalone server not inside tomcat's
> > > webapp.
> > > > > > > > I have  <parameter name="enableSwA">true</parameter>
in the
> > > > service.xml inside arr file. Inside tomcat server, I also  have this
> > > line in
> > > > the
> > > > > > > > ${CATLINA_HOME}/webapps/myapp/WEB-INF/conf/axis2.xml.
> > > > > > > > What I am missing?
> > > > > > > > Thanks for you time,
> > > > > > > > Jack
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Thilina Gunarathne - http://thilinag.blogspot.com
> > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > >
> > > > > > Some people lived like they will never die
> > > > > > and died like they have never lived
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Thilina Gunarathne  - http://thilinag.blogspot.com
> > > >
> > > >
> > > >
> > > > --
> > > >
> > > > Some people lived like they will never die
> > > > and died like they have never lived
> > >
> > >
> > >
> > > --
> > > Thilina Gunarathne - http://thilinag.blogspot.com
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > > For additional commands, e-mail: axis-user-help@ws.apache.org
> > >
> > >
> >
> >
> > --
> >
> > Some people lived like they will never die
> > and died like they have never lived
> >
>
>
>
> --
>
> Some people lived like they will never die
> and died like they have never lived
>



-- 
Thilina Gunarathne - http://thilinag.blogspot.com

Mime
View raw message