axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Thomas Manes" <atma...@gmail.com>
Subject Fwd: Posting on behalf of Hari C -- Help Please
Date Mon, 07 Apr 2008 02:35:01 GMT
---------- Forwarded message ----------
From: Hari C <hari.c@tcs.com>
Date: Sun, Apr 6, 2008 at 5:26 PM
Subject: Help Please
To: atmanes@gmail.com


Our project is having an existing webservice running in axis1.1.1.We were
 trying to create a new service in axis 1.3. and wanted to package the AAR
 in the same WAR file since both services are to be deployed together.

 Is is possible to have two services with different version to run in the
 same WAR? I noticed that some of the jar files are of the same name and my
 deployment process is overwriting 1.1.1 jar with 1.3 jars. IS it possible
 to include all the jars i require inside the corresponding AAR itself. I
 mean the 1.1.1 service AAR will have all the 1.1.1 jars and 1.3 service
 AAR will have all 1.3 jars?

 Project has got a constrain that the existing service should use 1.1.1. I
 think in this scenario i either need to move the new service to another
 WAR or use the 1.1.1 for the new service. Please advice.

Thanks and Regards

 Hari C
 Tata Consultancy Services
 Level 4, 225 Miller Street
 North Sydney 2060,
 Sydney - 2000,Nsw
 Australia
 Mailto: hari.c@tcs.com
 Website: http://www.tcs.com
 ____________________________________________
 Experience certainty.        IT Services
                        Business Solutions
                        Outsourcing
 ____________________________________________
----- Forwarded by Hari C/BLR/TCS on 07/04/2008 10:20 AM -----

 MAILER-DAEMON@apache.org

07/04/2008 09:51 AM

To prvs=hari.c=9752a3bf4@tcs.com

cc

Subject failure notice





Hi. This is the qmail-send program at apache.org.
 I'm afraid I wasn't able to deliver your message to the following addresses.
 This is a permanent error; I've given up. Sorry it didn't work out.

 <axis-user@ws.apache.org>:
 Sorry, only subscribers may post. If you are a subscriber, check to
be sure you are sending from your subscribed address. (#5.7.2)

 --- Below this line is a copy of the message.

 Return-Path: <prvs=hari.c=9752a3bf4@tcs.com>
 Received: (qmail 99247 invoked by uid 99); 6 Apr 2008 23:51:54 -0000
 Received: from athena.apache.org (HELO athena.apache.org) (140.211.11.136)
    by apache.org (qpsmtpd/0.29) with ESMTP; Sun, 06 Apr 2008 16:51:54 -0700
 X-ASF-Spam-Status: No, hits=-2.0 required=10.0
                 tests=HTML_MESSAGE,RCVD_IN_DNSWL_MED,SPF_PASS
 X-Spam-Check-By: apache.org
 Received-SPF: pass (athena.apache.org: local policy)
 Received: from [59.160.202.211] (HELO inblrg01.tcs.com) (59.160.202.211)
    by apache.org (qpsmtpd/0.29) with ESMTP; Sun, 06 Apr 2008 23:51:12 +0000
 X-IronPort-AV: E=Sophos;i="4.25,613,1199644200";
   d="scan'208";a="34686779"
 Received: from unknown (HELO inblrm02.tcs.com) ([172.19.144.225])
  by inblrg01.tcs.com with ESMTP; 07 Apr 2008 05:19:15 +0530
 In-Reply-To: <711261.94287.qm@web32805.mail.mud.yahoo.com>
 To: axis-user@ws.apache.org
 Subject: Axis Version!!
 MIME-Version: 1.0
 X-Mailer: Lotus Notes Release 7.0 August 18, 2005
 From: Hari C <hari.c@tcs.com>
 Message-ID: <OF546EAB75.5B76906A-ONCA257423.0081A3F8-CA257423.0082F49E@tcs.com>
 Date: Mon, 7 Apr 2008 10:49:13 +1100
 X-MIMETrack: Serialize by Router on InBlrM02/TCS(Release
6.5.5FP2HF415 | June 20, 2007) at
 04/07/2008 05:19:14,
                 Serialize complete at 04/07/2008 05:19:14
 Content-Type: multipart/alternative; boundary="=_alternative
0082F2E1CA257423_="
 X-Virus-Checked: Checked by ClamAV on apache.org

 This is a multipart message in MIME format.
 --=_alternative 0082F2E1CA257423_=
 Content-Transfer-Encoding: 7bit
 Content-Type: text/plain; charset="us-ascii"

 Hi All,

 Our project is having an existing webservice running in axis1.1.1.We were
 trying to create a new service in axis 1.3. and wanted to package the AAR
 in the same WAR file since both services are to be deployed together.

 Is is possible to have two services with different version to run in the
 same WAR? I noticed that some of the jar files are of the same name and my
 deployment process is overwriting 1.1.1 jar with 1.3 jars. IS it possible
 to include all the jars i require inside the corresponding AAR itself. I
 mean the 1.1.1 service AAR will have all the 1.1.1 jars and 1.3 service
 AAR will have all 1.3 jars?

 Project has got a constrain that the existing service should use 1.1.1. I
 think in this scenario i either need to move the new service to another
 WAR or use the 1.1.1 for the new service. Please advice.

 Thanks and Regards


 Hari C
 Mailto: hari.c@tcs.com
 ____________________________________________
 =====-----=====-----=====
 Notice: The information contained in this e-mail
 message and/or attachments to it may contain
 confidential or privileged information. If you are
 not the intended recipient, any dissemination, use,
 review, distribution, printing or copying of the
 information contained in this e-mail message
 and/or attachments to it are strictly prohibited. If
 you have received this communication in error,
 please notify us by reply e-mail or telephone and
 immediately and permanently delete the message
 and any attachments. Thank you



 --=_alternative 0082F2E1CA257423_=
 Content-Transfer-Encoding: 7bit
 Content-Type: text/html; charset="us-ascii"


 <br><font size=2 face="sans-serif">Hi All,</font>
 <br>
 <br><font size=2 face="sans-serif">Our project is having an existing webservice
 running in axis1.1.1.We were trying to create a new service in axis 1.3.
 and wanted to package the AAR in the same WAR file since both services
 are to be deployed together.</font>
 <br>
 <br><font size=2 face="sans-serif">Is is possible to have two services
 with different version to run in the same WAR? I noticed that some of the
 jar files are of the same name and my deployment process is overwriting
 1.1.1 jar with 1.3 jars. IS it possible to include all the jars i require
 inside the corresponding AAR itself. I mean the 1.1.1 service AAR will
 have all the 1.1.1 jars and 1.3 service AAR will have all 1.3 jars?</font>
 <br>
 <br><font size=2 face="sans-serif">Project has got a constrain that the
 existing service should use 1.1.1. I think in this scenario i either need
 to move the new service to another WAR or use the 1.1.1 for the new service.
 Please advice.</font>
 <br>
 <br><font size=2 face="sans-serif">Thanks and Regards</font>
 <br>
 <br><font size=2 face="sans-serif"><br>
 Hari C<br>
 Mailto: hari.c@tcs.com<br>
 ____________________________________________<br>
 </font><pre>=====-----=====-----=====
 Notice: The information contained in this e-mail
 message and/or attachments to it may contain
 confidential or privileged information. If you are
 not the intended recipient, any dissemination, use,
 review, distribution, printing or copying of the
 information contained in this e-mail message
 and/or attachments to it are strictly prohibited. If
 you have received this communication in error,
 please notify us by reply e-mail or telephone and
 immediately and permanently delete the message
 and any attachments. Thank you


 </pre>
 --=_alternative 0082F2E1CA257423_=--


ForwardSourceID:NT00004A82    =====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain
confidential or privileged information. If you are
not the intended recipient, any dissemination, use,
review, distribution, printing or copying of the
information contained in this e-mail message
and/or attachments to it are strictly prohibited. If
you have received this communication in error,
please notify us by reply e-mail or telephone and
immediately and permanently delete the message
and any attachments. Thank you

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message