axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepal jayasinghe <deep...@gmail.com>
Subject Re: [axis2] axis2 1.3 complextype with byte[] member variable, bug?
Date Thu, 17 Apr 2008 06:21:34 GMT
Holger Uhlitzsch wrote:
> Hi all,
>
> i think i found a bug in axis2 1.3 with POJOs.
>   
:)
> My POJO has two methods. One sending a object with a byte[] member and one returning
a object with byte[] member.
> The serialization of the object is valid and i can see in the sending out soap message
the base64 encoded byte[]. But the deserialization fails.
>   
What do you mean by fails ? did you get any exception ?
> In line 382 of class org.apache.axis2.databinding.utils.BeanUtil i have to change:
>
> partObj = deserialize(parameters, (OMElement)parts.getParent(),
>
> to:
>
> partObj = deserialize(parameters, parts,
>
> So i do not call deserialize() with the parent of parts (which is the xml element of
the byte[] member).
>
> and in line 308 change:
>
> return Base64.decode(beanElement.getFirstElement().getText());
>
> to:
>
> return Base64.decode(beanElement.getText());
>
> Now i just have to call getText() to get the base64 encoded content of the byte[] xml
element.
>
> I have to do this because call getFirstElement() doesn't ensure that the element is really
the byte[] element.
>
> But i'm not sure this is the right fix.
>   
as I remember correct we have done some testing with ADB stub and POJO 
services, however there we did not find any issues. So I need to double 
check this and confirm.

Thank you!
Deepal

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message