axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "McCullough, Ryan" <rmccullo...@rightnow.com>
Subject xml:id does not want to work
Date Mon, 07 Apr 2008 20:44:18 GMT
In my wsdl, I am importing an xsd schema file. That xsd file has an import:

 

<xs:schema elementFormDefault="qualified"

                 xmlns:xs="http://www.w3.org/2001/XMLSchema"

                 xmlns="urn:<sanitized>"

                 xmlns:rnt="urn:<sanitized>"

           targetNamespace="urn:<sanitized>">

 

  <xs:import namespace="http://www.w3.org/XML/1998/namespace"

                  schemaLocation="xml.xsd" />

 

xml.xsd comes from http://www.w3.org/2001/xml.xsd.

 

I then declare a base object that several other objects extend.

 

    <xs:complexType name="api_base">

        <xs:attribute ref="xml:id" />

        <xs:attribute ref="attr2" />

        <xs:attribute ref="attr3" />

        <xs:attribute name="attr4" type="xs:base64Binary" />

    </xs:complexType>

 

 

    <xs:complexType name="contact" >

        <xs:complexContent>

            <xs:extension base="api_base">

                <xs:sequence>

                    <!-Attributes go here-->

                </xs:sequence>

            </xs:extension>

        </xs:complexContent>

    </xs:complexType>

 

 

The problem is that Axis does not seem to like the xml:id. The xml:id
attribute is not declared in objects.

 

Ideas?

 

Ryan McCullough | RightNow Technologies | Integration Tools Engineer

406-556-3162 office | Bozeman, MT |  <mailto:rmccullough@rightnow.com>
rmccullough@rightnow.com |  <http://www.rightnow.com/>
http://www.rightnow.com

 


Mime
View raw message