axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: [Axis2] Problem with handler and services.xml
Date Fri, 07 Mar 2008 13:44:58 GMT
Good Morning Matthias

Can you confirm the module is located in /WEB-INF/modules folder?
can you confirm the modules.list contains the entry for the name of module?

Module Engaged to service
In the /META-INF/services.xml can you view the service entry to include the
module name e.g.  <module ref="addressing" /> ?

Global available Modules
Can you see your module ref <module ref="addressing" /> in
/WEB-INF/conf/axis2.xml ?

?
Martin-
----- Original Message -----
From: <Matthias.Gaiser@t-systems.com>
To: <axis-user@ws.apache.org>
Sent: Friday, March 07, 2008 2:50 AM
Subject: AW: [Axis2] Problem with handler and services.xml


> Hi Deepal,
>
> I have created an axis2 project with eclipse which arranged the axis2
folder structure for me. By placing my module in the
"WEB-INF/modules"-folder I deploy it to axis2.
> When I use the Axis2 Admin Console I can see my module engaged for my
service.But it still does not work. That is the weird point I do not get in
my mind, everything seems to be in place...
>
> Any more help?
>
> Thank you,
> Matthias.
>
> -----Ursprüngliche Nachricht-----
> Von: Deepal jayasinghe [mailto:deepalk@gmail.com]
> Gesendet: Freitag, 7. März 2008 07:53
> An: axis-user@ws.apache.org
> Betreff: Re: [Axis2] Problem with handler and services.xml
>
> Matthias.Gaiser@t-systems.com wrote:
> >
> > Hi all,
> >
> >
> >
> > I am writing my own module, containing a handler.
> >
> >
> >
> > For this, I have completed following steps.
> >
> > - I have specified the handler for a custom phase (in the InFlow) in
> > the module.xml
> >
> > - I have added the custom phase to the axis2.xml (in the InFlow)
> >
> > - I have added a <module ref=”…”> to the services.xml
> >
> >
> >
> > The module is being loaded, but the problem is that my handler is not
> > executed when I call my service.
> >
> >
> >
> > It worked when I directly specified the handler in the custom phase in
> > the axis2.xml, but that is not the way it is supposed to be done, is it?
> >
> >
> >
> > Any ideas?
> >
> If you are using axis2.war as your deployment mechanism then  from the
> administration console you can see whether you handler is there or not.
> Please check that and confirm first , if it is there then let's see what
> we can do
>
> Thank you,
> Deepal
> >
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message