axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Aneel.Mur...@gxs.com>
Subject RE: [Axis2] Problems running Axis2 Client on Weblogic 9.2
Date Wed, 12 Mar 2008 18:14:20 GMT
I finally got past this issue. It turns out jrocket doesn't do a good job in throwing ClassNotFound
Exceptions. Instead it is throwing the following error. Switching the JVM to Sun showed me
the missing classes.

________________________________
From: Aneel.Murari@gxs.com [mailto:Aneel.Murari@gxs.com]
Sent: Wednesday, March 12, 2008 9:16 AM
To: axis-user@ws.apache.org
Subject: RE: [Axis2] Problems running Axis2 Client on Weblogic 9.2

Hi Satish,

Thanks for your reply. I am not running axis2 as a server. I am just using it as a Web Service
client and hence I placed all my axis related jars under META-INF/lib of the EJB deployment.
Am I required to install the Axis web application?

Thanks,
Aneel

________________________________
From: Kannan, Sathish (Exchange) [mailto:skannan@Bear.com]
Sent: Tuesday, March 11, 2008 6:07 PM
To: axis-user@ws.apache.org
Subject: RE: [Axis2] Problems running Axis2 Client on Weblogic 9.2

Looks like your weblogic jars getting conflicted with axis. Create a weblogic.xml and place
it under WEB-INF/conf directory of axis web application

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<weblogic-web-app
  xmlns="http://www.bea.com/ns/weblogic/90"
  xmlns:j2ee="http://java.sun.com/xml/ns/j2ee"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.bea.com/ns/weblogic/90 http://www.bea.com/ns/weblogic/90/weblogic-web-app.xsd">

 <weblogic-web-app>
       <container-descriptor>
            <prefer-web-inf-classes>true</prefer-web-inf-classes>
      </container-descriptor>
 </weblogic-web-app>

</weblogic-web-app>



________________________________
From: Aneel.Murari@gxs.com [mailto:Aneel.Murari@gxs.com]
Sent: Tuesday, March 11, 2008 4:20 PM
To: axis-user@ws.apache.org
Subject: [Axis2] Problems running Axis2 Client on Weblogic 9.2

Hi,

I have a MDB deployed in weblogic 9.2. My MDB reads a message from the JMS = queue and invokes
a Web Service. I am using Axis2 as a client to invoke the web service(s). The code works fine
when I run it from my local eclipse environment with all the axis2 jars in the classpath.
So, as part of my MDB deployment, I am keeping all the axis2 and dependent jars under META-INF/lib
 of the EJB directory. But when the code is run on Weblogic, deployed as MDB, I get this following
exception.

2008-03-11 14:40:12,847 GMT ERROR  app.dev.tiger.eu.gxs.com AIProfileCreator com.gxs.services.aiprofilecreator.ejb.SubscriptionEventBean.onMessage
java.lang.InternalError: erroneous handlers at com.gxs.services.aiprofilecreator.common.AIProfileCreator.handleSubscriptionEvent(AIProfileCreator.java
:71)

It seems like I am getting this error when the call to the method where I create my stub happens.
I confirmed this by deploying a test version of the code which by passes the web service call
and that works fine. It seems like I am missing some kind of Axis2 configuration on weblogic.
If I just want to run Axis2 client inside an EJB, is the setup I have mentioned above going
to work?

I appreciate any help in resolving this issue.

Thanks,
Aneel


Mime
View raw message