axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Capilla Castillo, Esther" <ecapi...@indra.es>
Subject RE: The endpoint reference (EPR) for the Operation not found
Date Wed, 05 Mar 2008 15:27:48 GMT
No, my webservices are in http://localhost:7001/axis2/services/WsVerDocumento

The services list show:
Available services
WsVerDocumento
Service EPR : http://localhost:7001/axis2/services/WsVerDocumento
Service Description : Este WebService permita bajar un documento del repositorio de Documentum
Service Status : Active
Available Operations

    * sendAttachment

-----Mensaje original-----
De: csethil@gmail.com [mailto:csethil@gmail.com] 
Enviado el: miércoles, 05 de marzo de 2008 16:21
Para: axis-user@ws.apache.org
Asunto: Re: The endpoint reference (EPR) for the Operation not found

Are you sure that your service is deployed... Can you see it in the
service listing that can be accessed by going to
http://localhost:8080/axis2 (change port & host accordingly) then
click the services link..

Try to capture and post your request.. You can use tcpmon
(http://ws.apache.org/commons/tcpmon) to capture the messages..

thanks,
Thilina

On 3/5/08, Capilla Castillo, Esther <ecapilla@indra.es> wrote:
> When I invoke my webservice from the client, the exception is:
> org.apache.axis2.AxisFault: unknown
> 	at
> org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:287)
> 	at
> org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:457)
> 	at
> org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:399)
> 	at clientesAxis2.VerDocumentoCliente.main(VerDocumentoCliente.java:91)
>
>
>
> -----Mensaje original-----
> De: Michele Mazzucco [mailto:Michele.Mazzucco@ncl.ac.uk]
> Enviado el: miércoles, 05 de marzo de 2008 14:33
> Para: axis-user@ws.apache.org
> Asunto: Re: The endpoint reference (EPR) for the Operation not found
>
> What about the protocol (I'm not expert with MTOM -- so I might be
> wrong)?
>
> options.setTransportInProtocol(Constants.TRANSPORT_HTTP); // set
> according to the protocol in operation
> This is needed (if MTOM is not used), otherwise an error like "cannot
> infer transport..." occurs.
>
> Michele
>
> On 5 Mar 2008, at 12:51, Capilla Castillo, Esther wrote:
>
> > In my client I have the following code to set options:
> > 		Options options = new Options();
> > 		options.setTo(targetEPR);
> > 		options.setAction("sendAttachment");
> > 		
> > 		
> > 		options.setProperty(Constants.Configuration.ENABLE_MTOM,
> > Constants.VALUE_TRUE);
> > 			
> > 		options.setTimeOutInMilliSeconds(10000);
> > 		
> > 		ServiceClient sender = new ServiceClient();
> > 		sender.setOptions(options);
> >
> > -----Mensaje original-----
> > De: Michele Mazzucco [mailto:Michele.Mazzucco@ncl.ac.uk]
> > Enviado el: miércoles, 05 de marzo de 2008 13:45
> > Para: axis-user@ws.apache.org
> > Asunto: Re: The endpoint reference (EPR) for the Operation not found
> >
> > Try to call options.setAction("sendAttachment");
> >
> > Michele
> >
> > On 5 Mar 2008, at 12:39, Capilla Castillo, Esther wrote:
> >
> >> This is the SOAP request:
> >>
> >> <soapenv:Reason>
> >> −
> >> 	<soapenv:Text>
> >> The endpoint reference (EPR) for the Operation not found is /axis2/
> >> services/WsVerDocumento and the WSA Action = null
> >> </soapenv:Text>
> >> </soapenv:Reason>
> >>
> >> -----Mensaje original-----
> >> De: Deepal jayasinghe [mailto:deepalk@gmail.com]
> >> Enviado el: miércoles, 05 de marzo de 2008 13:37
> >> Para: axis-user@ws.apache.org
> >> Asunto: Re: The endpoint reference (EPR) for the Operation not found
> >>
> >>
> >> Any possibility of looking at the SOAP request (including HTTP
> >> headers)
> >> , then I may be able to give you an answer.
> >>
> >> Thank you,
> >> Deepal
> >>> Hi all!
> >>> I'm deployed a WebServices in beaWeblogic 9.2, but I've a problem,
> >>> when
> >>> I invoke the Services I obtain the follow message:
> >>> The endpoint reference (EPR) for the Operation not found is
> >>> /axis2/services/WsVerDocumento and the WSA Action = null
> >>> I think that my problem is in the services.xml, but I don't know. My
> >>> services.xml is that:
> >>> <service name="WsVerDocumento">
> >>>     <Description>
> >>>         Este WebService permita bajar un documento del
> >>> repositorio de
> >>> Documentum
> >>>     </Description>
> >>> 	<parameter name="enableMTOM">true</parameter>
> >>>     <parameter name="ServiceClass"
> >>> locked="false">com.soluziona.documental.servicios2.verdocumento.VerD
> >>> o
> >>> cum
> >>> entoWebService</parameter>
> >>>     <operation name="sendAttachment">
> >>> 		<actionMapping>sendAttachment</actionMapping>
> >>> 		<messageReceiver
> >>> class="org.apache.axis2.receivers.RawXMLINOutMessageReceiver" />
> >>>     </operation>
> >>> </service>
> >>>
> >>> Thanks!
> >>> Esther
> >>>
> >>> --------------------------------------------------------------------
> >>> -
> >>> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >>> For additional commands, e-mail: axis-user-help@ws.apache.org
> >>>
> >>>
> >>>
> >>
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >> For additional commands, e-mail: axis-user-help@ws.apache.org
> >>
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Thilina Gunarathne  - http://thilinag.blogspot.com
Mime
View raw message