axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gaurav Lall <learnframewo...@gmail.com>
Subject [Axis2] No xsi:type in the response elements
Date Wed, 09 Jan 2008 07:46:38 GMT
Hi all ,

We are doing migration to axis2 from axis1, we are using xmlnbeans as 
data binding. mechanism.I am using  axis 2 version 1.3

We are observing difference in the responses

   1. there is no xsi:type coming out for the response
   2. Also the namespaces are coming for each element in axis 2 response
      ? I would idealy like to use the prefixes to reduce the size of
      the payload
   3. Is there a configuration parameter which controls the emission of
      xsi:type

Any direction or pointers would be of great help ?

-------------------AXIS 1
<off:productCategory>
  <off:controlType>multiSelect</off:controlType>
  <off:categoryType 
xsi:type="*xs:string*">alaCarteResidential.alaCarteResidential</off:categoryType>


  <off:categoryName>ODUSelection.ODUSelection</off:categoryName>
  <ent:description xsi:type="*xs:string*">ODU Selection</ent:description>
------------Axis2
<productCategory 
xmlns="http://ei.com/schemas/wsdl/orderServices/v3_0/offer">
  <controlType 
xmlns="http://ei.com/schemas/wsdl/orderServices/v3_0/offer">multiSelect</controlType>


  <categoryType 
xmlns="http://ei.com/schemas/wsdl/orderServices/v3_0/offer">alaCarteResidential.alaCarteResidential</categoryType>


  <categoryName 
xmlns="http://ei.com/schemas/wsdl/orderServices/v3_0/offer">ODUSelection.ODUSelection<l</categoryName>


  <description xmlns="http://ei.com/schemas/entities/v3_1">A La Carte 
Programming</description>

Thanks for the help
Gaurav

Mime
View raw message