axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Gainty" <mgai...@hotmail.com>
Subject Re: org.xml.sax.SAXException: SimpleDeserializer encountered a child element, which is NOT expected, in something it was trying to deserialize.
Date Tue, 04 Dec 2007 02:06:45 GMT
do these security handlers have any advantages over rampart ?

M-
  ----- Original Message ----- 
  From: Peter 
  To: axis-user@ws.apache.org 
  Sent: Monday, December 03, 2007 7:56 PM
  Subject: Re: org.xml.sax.SAXException: SimpleDeserializer encountered a child element, which
is NOT expected, in something it was trying to deserialize.


  We're using 3rd party security handlers that only work in Axis 1.2.1.  

  Srinivas Gupta

  Martin Gainty <mgainty@hotmail.com> wrote:
    Synivas-

    why not upgrade?

    M--
      ----- Original Message ----- 
      From: Srinivas Gupta 
      To: axis-user@ws.apache.org 
      Sent: Monday, December 03, 2007 5:22 PM
      Subject: org.xml.sax.SAXException: SimpleDeserializer encountered a child element, which
is NOT expected, in something it was trying to deserialize.


      Hello,

      I have a test client whose classes were generated by Axis 1.2.1 wsdl2java, and I use
this to hit services also generated by wsdl2java.  The services comprise what we call a "data
provider".  I have used this test client against many data providers without any problems.
 But now I'm getting the following exception when I try to hit a new data provider:

      org.xml.sax.SAXException: SimpleDeserializer encountered a child element, which is NOT
expected, in something it was trying to deserialize

      This data provider is using the same WSDL as all of the other data providers.  The only
thing that might be different with this data provider is its server-config.wsdd.  I've tried
tweaking the server-config.wsdd, but to no avail.  For example, I tried changing style="document"
to style="rpc".  I wish that I could upgrade to Axis 1.4 or Axis 2.0, but we are constrained
to Axis 1.2.1 because of project requirements...

      Does anyone have any suggestions?

      Thank you.

      Srinivas Gupta




--------------------------------------------------------------------------
      Be a better pen pal. Text or chat with friends inside Yahoo! Mail. See how.




------------------------------------------------------------------------------
  Be a better pen pal. Text or chat with friends inside Yahoo! Mail. See how.
Mime
View raw message