axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roman Schönbichler" <roman.schoenbich...@matkovits.at>
Subject Bad version number in .class file
Date Mon, 10 Dec 2007 12:41:28 GMT
Hey Guys!

If generated a WS (with wsdl2java) which worked perfectly in JRE1.6
and Axis2.

Now I've got the problem, that it needs to be run under JRE1.5

I've removed alle Java 1.6 components, and reconfigured my path and
java_home variables to point to the jre/jdk 1.5 directories.
I've also changed the JRE in Eclipse to jre1.5.

Then I've recreated the WS, using wsdl2java (it told me that it uses
jre1.5).

After that I've filled in the buisness logic, and made a new .aar
file.

When I try to deploy the .aar file, axis tells me:
or.apache.axis2.deployment.DeploymentException:
java.lang.UnsupportedClassVersionError: Bad version number in .class
file

I don't have a clue where this could come from, since I've rebuilt
everything!

I hope someone can give me some hints!

Greets
Roman


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message