axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ndthuy <nd_t...@yahoo.com>
Subject Adding WS-Security to an embedded axis2 web application
Date Wed, 05 Dec 2007 17:03:51 GMT

All,

Does anyone know how to set up WS-Security to an embedded Axis2 web
application ? I am using Axis2 1.3 and Rampart 1.3. This is my set up for
embedded Axis2 web application.

WebApp:
        + src
        + WebRoot
            + conf
            + lib
            + modules
            + services
               + common
               + META-INF
                  + AdminRetrieveUserService.wsdl
                  + apschema.xsd
                  + services.xml

I added rampart-1.3.mar to the modules folder. I also added all the rampart
libraries. I added the following to services.xml :

<module ref="rampart"/>

<parameter name="Inflowsecurity">
        	<action>
        		<items>Timestamp</items>
        	</action>
        </parameter>
        <parameter name="Outflowsecurity">
        	<action>
        		<items>Timestamp</items>
        	</action>
        </parameter>

And I haven't modified my client yet. I supposed to receive the error if I
send my message without the soap header. However nothing happened and I
still received a successful soap message back. Does anyone try to do this
before?

Thanks.
-- 
View this message in context: http://www.nabble.com/Adding-WS-Security-to-an-embedded-axis2-web-application-tf4950998.html#a14175976
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message