axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michele Mazzucco <Michele.Mazzu...@ncl.ac.uk>
Subject [Axis2] Problem with ServiceClient + custom ConfigurationContext
Date Fri, 07 Dec 2007 14:34:29 GMT
Hi all,

the scenario I'm trying to set up is the following:
1 - My (statefull) web service exposes in-only operations
2 - Incoming requests are queued and processed by a single thread (this
is because a "decision" has to be taken depending on the state)
3 - Once the result is available the worker thread uses the
WS-addressing information to send the response back to the client (the
client sends the request using sendReceiveNonBlocking()) -- this task
could be eventually be accomplished using a pool of workers

Here's the problem:
1 - If the ServiceClient used to send the response is the "default" one
(i.e. created using new ServiceClient()) everything works fine. However
in a real scenario one would like to cache the http client in order to
minimize system resources usage, so a custom ConfigurationContext is
used
2 - If the ServiceClient is instantiated providing a (custom)
ConfigurationContext the response is not delivered. The thrown exception
depends on the ConfigurationContext:
2a - ConfigurationContextFactory.createEmptyConfigurationContext():
Transport out has not been set
2b - ConfigurationContextFactory.createDefaultConfigurationContext():
The endpoint reference (EPR) for the Operation not found is
172.16.98.1/axis2/services/anonService1 and the WSA Action = urn:success
2c -
ConfigurationContextFactory.createConfigurationContextFromFileSystem(null, null): same error
as 2b


This scenario used to work with Axis2 1.1.
Please find attached the test case as eclipse project.


Any idea?
Michele

Mime
View raw message