axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pantvaidya, Vishwajit" <vpant...@selectica.com>
Subject [Axis2] Deployment error "Filename must not be null": Deployment Engine calls DeploymentFileData with null args
Date Mon, 12 Nov 2007 22:26:13 GMT
I am using tomcat 5.5 and have deployed in an exploded format (not a war) i.e. my services.xml
is copied to the WEB-INF folder and classes generated from wsdl using Axis2 nightly build
of Nov 6 have been copied to WEB-INF\classes. Then at tomcat startup I get the following error:

[12 Nov 2007 14:16:58,449][vpantvaidya@selectica.com][vishp-t40] ERROR [[/]] Servlet threw
load() exception
java.lang.IllegalArgumentException: Filename must not be null
at org.apache.axis2.deployment.repository.util.DeploymentFileData.<init>(DeploymentFileData.java:43)
at org.apache.axis2.deployment.repository.util.DeploymentFileData.<init>(DeploymentFileData.java:48)
at org.apache.axis2.deployment.DeploymentEngine.buildServiceGroup(DeploymentEngine.java:1028)
at org.apache.axis2.deployment.WarBasedAxisConfigurator.loadServicesFromWebInf(WarBasedAxisConfigurator.java:309)
at org.apache.axis2.deployment.WarBasedAxisConfigurator.loadServices(WarBasedAxisConfigurator.java:270)
at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:78)
I looked into the Axis2 code and see that DeploymentEngine class is calling DeploymentFileData.init
with both args null - which is why I get the error. Any idea what could be the problem here?


Mime
View raw message