axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chily <surriz...@hotmail.com>
Subject Re: [AXIS2] export a webservices with wsdl 1.1
Date Mon, 05 Nov 2007 16:44:33 GMT

Hi paul thank you very much.
But with this url (http://localhost:8080/axis2/services/YourService?wsdl
axis2 expoirt the wsdl with 2.0 vesrsion (same as with
services/YourService?wsdl2 off course).
I read we can put some parameter like :
http://sapo:8080/seguridad-web/services/AuthenticationService?wsdl=wsdl1.1

but the server response with this :
<pre>
- <error>
  <description>Unable to generate WSDL 1.1 for this service</description> 
  <reason>If you wish Axis2 to automatically generate the WSDL 1.1, then
please +set useOriginalwsdl as false in your services.xml</reason> 
  </error>
</pre>

y try to add this parameter to the service definition but nothing change.
<code>
	<service name="AuthenticationService" >
	    <description>
	         Authentication Service.
	    </description>
	    <parameter
name="ServiceClass">ar.bcra.seguridad.client.servicio.AuthenticationService</parameter>
	    <parameter name="ServiceObjectSupplier" locked="false">
	              
org.apache.axis2.extensions.spring.receivers.SpringAppContextAwareObjectSupplier
	   	</parameter>
	   	<parameter name="SpringBeanName">authenticationService</parameter>
	   	<parameter name="useOriginalwsdl">false</parameter>
</code>
....



Any help?

pzfreo wrote:
> 
> Chily
> 
> As far as I know, Axis2 exposes both WSDL1.1 and WSDL2.0. You should look
> at
> http://localhost:8080/axis2/services/YourService?wsdl and wsdl2
> 
> Paul
> 
> On 11/5/07, Chily <surrizola@hotmail.com> wrote:
>>
>>
>> Hi, i am new in axis2, and i export a lot of webservices from my
>> applicacion
>> (spring based application).
>> By defaul, axis2 export this services with wsdl 2.0 service contract
>> definition (dynamic wsdl generation), but i need to export them with the
>> wsdl 1.1 version.
>> Anyone now if there is any configuration parameter to set the wsdl
>> version?
>> --
>> View this message in context:
>> http://www.nabble.com/-AXIS2--export-a-webservices-with-wsdl-1.1-tf4751943.html#a13587786
>> Sent from the Axis - User mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-user-help@ws.apache.org
>>
>>
> 
> 
> -- 
> Paul Fremantle
> Co-Founder and VP of Technical Sales, WSO2
> OASIS WS-RX TC Co-chair
> 
> blog: http://pzf.fremantle.org
> paul@wso2.com
> 
> "Oxygenating the Web Service Platform", www.wso2.com
> 
> 

-- 
View this message in context: http://www.nabble.com/-AXIS2--export-a-webservices-with-wsdl-1.1-tf4751943.html#a13590348
Sent from the Axis - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message