axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cset...@gmail.com
Subject Re: problem of soap version in axis2/java 1.2
Date Fri, 12 Oct 2007 18:31:55 GMT
This can be due to the action="""" parameter of the content type of
the MIME message generated by Axis2/c (Notice the unnecessary
quotes)...  Modify your Axis2.xml of the server to send the full stack
trace with faults and post the full stack trace..

Also log a JIRA with Axis2/C.

~Thilina



On 10/12/07, donald yang <donaldyy@googlemail.com> wrote:
> Hi Keith,
>
> Thanks for your reply. The problem I currently have is that I will reveive
> an exception "Invalid Content Type Field in the Mime Message"  as a SOAP
> reply when I set the soap version to 1.2 in the web service client written
> using AXIS2/C 1.0. But when I set the soap version to 1.1 in the web service
> client, it works as what I expect.  The environment for this test case is as
> follows:
>
>      Web service Client: use AXIS2/C 1.0
>      Web Service: POJO web serice and AXIS2/JAVA 1.2
>      WSDL : automatically generated by AXIS2/JAVA 1.2 which has three port:
> HTTP, SOAP1.2, SOAP1.1
>
>     The soap messages for this test case can be found in the attachment.
>
> best regards
> donald
>
> On 10/12/07, keith chapman <keithgchapman@gmail.com> wrote:
> >
> > No need to change anything. If the request is SOAP 1.1 the response will
> > be SOAP 1.1. if it is SOAP 1.2 the response will be SOAP 1.2.
> >
> > Thanks,
> > Keith.
> >
> > On 10/12/07, donald yang <donaldyy@googlemail.com> wrote:
> > >
> > > Hi everyone,
> > >
> > > First I wrote a simple web service using AXIS2/JAVA 1.2. Then I wrote a
> > > web service client test case using AXIS2/C 1.0 to access the web
> > > service. In the client,  I have enabled MTOM even if there is no binaary
> > > attachment to send in fact and set the SOAP version to SOAP 1.2. I got
> > > one exception
> > >
> > >      " Invalid Content Type Field in the Mime Message"
> > >
> > > Then I compared the soap request created by AXIS2/C 1.0 with the soap
> > > request created by AXIS2/JAVA 1.2. I found the major difference is that
> > > the value of start-info is "application/xop+xml" not "text/xml" in the
> soap
> > > request created by AXIS2/C.
> > >
> > > Then I resetting the SOAP vesion to SOAP 1.1 in the web service client
> > > wrote using AXIS2/C 1.0. It works fine. But when I looked at the wsdl
> > > generated by AXIS2/JAVA 1.2, it has three ports, HTTP PORT, SOAP
> 1.1PORT,
> > > SOAP1.2 PORT. That means it should support the SOAP request with version
> > > 1.2. Is there anyone can tell me how to enable  the server support SOAP
> > > 1.2 in AXIS2/JAVA 1.2? many thanks in advnace.
> > >
> > > best regards
> > > yong
> > >
> > >
> > >
> >
> >
> > --
> > Keith Chapman
> > WSO2 Inc.
> > Oxygen for Web Services Developers.
> > http://wso2.org/
>


-- 
Thilina Gunarathne  - http://thilinag.blogspot.com

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message