axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Fremantle" <pzf...@gmail.com>
Subject Re: AXIS2 and .NET Interop
Date Fri, 26 Oct 2007 10:19:44 GMT
Maxim

What version of .NET is this? I notice that the SOAP 1.1 calls are all
working and SOAP1.2 isn't.

Try

stub._getServiceClient().getOptions().setSoapVersionURI(
org.apache.axis2.namespace.Constants.URI_SOAP11_ENV);

Paul


On 10/26/07, Maxim Geraskyn <maxim.ge@gmail.com> wrote:
>
> > Is there any error log on the .NET side?
>
> Hmm, may be, have to check
>
> > I can't see anything really wrong with the Axis2 request. How did you
> > generate the client?
>
> As I mentioned xml part of request is fine. If I change headers it
> works perfectly.
> Client was generated by WSDL2Java
>
>         <target name="testjava">
>               <java classname="org.apache.axis2.wsdl.WSDL2Java"
>                   classpathref="compile.classpath"
>                   fork="true">
> <!--              <arg value="-d"/>
>                   <arg value="xmlbeans"/>-->
>                   <arg value="-uri"/>
>                   <arg value="http://localhost:3353/Service1.asmx?WSDL"/>
>                   <arg value="${work}\test.wsdl"/>
>                   <arg value="-o"/>
>                   <arg file="${src}"/>
>                   <arg value="-f"/>
>                   <arg value="-s"/>
>                 </java>
>         </target>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Paul Fremantle
Co-Founder and VP of Technical Sales, WSO2
OASIS WS-RX TC Co-chair

blog: http://pzf.fremantle.org
paul@wso2.com

"Oxygenating the Web Service Platform", www.wso2.com

Mime
View raw message