axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Fremantle" <pzf...@gmail.com>
Subject Re: Problem with AXIS2 client against an XFire server
Date Wed, 03 Oct 2007 16:49:51 GMT
It seems maybe you are targeting the request against the WSDL url
http://engineoushamburg.dyndns.org:6980/Update_BeamInterfaceInterface?wsdl
not the SOAP URL
http://engineoushamburg.dyndns.org:6980/Update_BeamInterfaceInterface

I tried building a simple client (ADB not XMLBeans)

wsdl2java.bat -uri
http://engineoushamburg.dyndns.org:6980/Update_BeamInterfaceInterface?wsdl
-uw

I set it to go through a local TCPMON running as a proxy on port 8888
so I could see the XML in/out (you can comment that out if you like).

I didn't get a success --- because I have no clue what parameters to
send in. I got a fault back "empty string".

Here is the client

package defaultnamespace;

import java.rmi.RemoteException;
import org.apache.axis2.transport.http.HTTPConstants;
import org.apache.axis2.transport.http.HttpTransportProperties.ProxyProperties;
import defaultnamespace.Update_BeamInterfaceInterfaceStub.ResultUpdate_BeamInterface;

public class Main {
	public static void main(String[] args) throws RemoteException {
		
		Update_BeamInterfaceInterfaceStub stub = new
Update_BeamInterfaceInterfaceStub();
		ProxyProperties pp = new ProxyProperties();
		pp.setProxyName("localhost");
		pp.setProxyPort(8888);
		
		stub._getServiceClient().getOptions().setProperty(HTTPConstants.PROXY, pp);
		ResultUpdate_BeamInterface result = stub.executeWorkflow("a", "b", "c", 30.1);
		System.out.println(result.getMass());
		
	}
}

Regards,

Paul

On 10/3/07, Patrick Houbaux <patrick.houbaux@eurostep.com> wrote:
> Hi all,
>
> I have generated a client stub using WSDL2Java using XMLBeans against
> the following WSDL apparently created with XFire:
> http://engineoushamburg.dyndns.org:6980/Update_BeamInterfaceInterface?wsdl
>
> When I invoke the only method from this webservice with the AXIS2
> generated stub I'm getting the following exception:
>
> org.apache.axis2.AxisFault: First Element must contain the local name,
> Envelope , but found definitions
>         at org.apache.axis2.AxisFault.makeFault(AxisFault.java:417)
>         at
> org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:89)
>         at
> org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:326)
>         at
> org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:389)
>         at
> org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:211)
>         at
> org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
>         at
> defaultnamespace.Update_BeamInterfaceInterfaceStub.executeWorkflow(Update_BeamInterfaceInterfaceStub.java:144)
>         at com.eurostep.test.TestFiperUB.main(TestFiperUB.java:45)
> Caused by: org.apache.axiom.soap.SOAPProcessingException: First Element
> must contain the local name, Envelope , but found definitions
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.constructNode(StAXSOAPModelBuilder.java:219)
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.createOMElement(StAXSOAPModelBuilder.java:177)
>         at
> org.apache.axiom.om.impl.builder.StAXOMBuilder.next(StAXOMBuilder.java:163)
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.getSOAPEnvelope(StAXSOAPModelBuilder.java:161)
>         at
> org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder.<init>(StAXSOAPModelBuilder.java:110)
>         at
> org.apache.axis2.builder.SOAPBuilder.processDocument(SOAPBuilder.java:53)
>         at
> org.apache.axis2.transport.TransportUtils.createDocumentElement(TransportUtils.java:160)
>         at
> org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:111)
>         at
> org.apache.axis2.transport.TransportUtils.createSOAPMessage(TransportUtils.java:87)
>         ... 6 more
>
> What does it mean?
> Are AXIS2 and XFire compatible?
>
> To me it seems the XFire server doesn't return a correct SOAP message.
> Am I right?
>
> Thanks for any help.
>
> Cheers,
> Patrick.
>
> This message contains information that may be privileged or confidential and is the property
of Eurostep Group. It is intended only for the person to whom it is addressed. If you are
not the intended recipient, you are not authorized to read, print, retain, copy, disseminate,
distribute, or use this message or any part thereof. If you receive this message in error,
please notify the sender immediately and delete all copies of this message.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Paul Fremantle
Co-Founder and VP of Technical Sales, WSO2
OASIS WS-RX TC Co-chair

blog: http://pzf.fremantle.org
paul@wso2.com

"Oxygenating the Web Service Platform", www.wso2.com

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message