axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Maes" <jm...@materialogic.com>
Subject RE: [Axis2] Deploying axis2.war within an Embedded Tomcat 5.5 server - axis2/services returning "The service cannot be found for the endpoint reference"
Date Tue, 23 Oct 2007 19:41:41 GMT
After digging into the Axis code, it looks like the problem is caused by the
following

The RequestDispatch returned from 

httpServletRequest.getRequestDispatcher(Constants.AXIS_WEB_CONTENT_ROOT +
jspName).include(httpServletRequest, httpServletResponse); 
in AbstractAgent.java (renderView method) 

is null. 

The following are the inputs that were passed into that call. 

Constants.AXIS_WEB_CONTENT_ROOT [/axis2-web/]
jspName                         [listServices.jsp]



I assume that this all points to something miss configured on my end on my
part, but I am out of ideas.  Does this help shed any light on the issue for
anyone?





James Maes
Software Architect
Materialogic
PH: 800-333-7144
PH: 314-997-4342 Ext. 3422
FX: 314-997-7814


-----Original Message-----
From: James Maes [mailto:jmaes@materialogic.com] 
Sent: Tuesday, October 23, 2007 12:46 PM
To: axis-user@ws.apache.org
Subject: RE: [Axis2] Deploying axis2.war within an Embedded Tomcat 5.5
server - axis2/services returning "The service cannot be found for the
endpoint reference"

When requesting the URL (http://BLAHBLAH/axis2/axis2-web/)
I get this response

HTTP Status 404 - /axis2/axis2-web/
----------------------------------------------------------------------------
----
type Status report
message /axis2/axis2-web/
description The requested resource (/axis2/axis2-web/) is not available.
----------------------------------------------------------------------------
----
Apache Tomcat/5.5.17

And this on the server console 

[java] Oct-23-07 12:45:04.917 : ERROR : http-8081-Processor3 :
g.apache.catalina.core.StandardHostValve : Exception Processing
ErrorPage[errorCode=404, location=/axis2-web/Error/error404.jsp]
     [java] java.lang.NullPointerException
     [java]     at
org.apache.catalina.core.StandardHostValve.custom(StandardHostValve.java:363
)
     [java]     at
org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:284
)
     [java]     at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:136
)
     [java]     at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105
)
     [java]     at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:107)
     [java]     at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
     [java]     at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
     [java]     at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC
onnection(Http11BaseProtocol.java:664)
     [java]     at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav
a:527)
     [java]     at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo
rkerThread.java:80)
     [java]     at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:684)
     [java]     at java.lang.Thread.run(Thread.java:595)












James Maes
Software Architect
Materialogic
PH: 800-333-7144
PH: 314-997-4342 Ext. 3422
FX: 314-997-7814

From: Upul Godage [mailto:upulg.dev@gmail.com] 
Sent: Tuesday, October 23, 2007 12:37 PM
To: axis-user@ws.apache.org
Subject: Re: [Axis2] Deploying axis2.war within an Embedded Tomcat 5.5
server - axis2/services returning "The service cannot be found for the
endpoint reference"

Check accessing these links in your server.

http://blahblash/axis2/axis2-web/
For console home page

http://blahblash/axis2/services/listServices 
For deployed services

Upul
On 10/23/07, James Maes <jmaes@materialogic.com> wrote:
Maybe someone can give a little insight into the issue(s) that I am having.

We are trying to embed Axis2 (1.3) into a internal application via Tomcat
(5.5)
Tomcat seems to be working fine (it's used for other war deployments) and 
the axis2.war deploys fine (see below)

Deployment code
         Context context = embedded.createContext("/axis2", "axis2.war");
         context.setReloadable(false);
         host.addChild (context);

War being deployed
     [java] Oct-23-07 11:36:11.081 : INFO  : main                 :
org.apache.catalina.core.StandardEngine : Starting Servlet Engine: Apache
Tomcat/5.5.17
     [java] Oct-23-07 11:36: 11.091 : INFO  : main                 :
org.apache.catalina.core.StandardHost : XML validation disabled
     [java] Oct-23-07 11:36:11.293 : INFO  : main                 :
rg.apache.catalina.startup.ContextConfig : No default web.xml
     [java] Oct-23-07 11:36:11.915 : INFO  : main                 :
g.apache.axis2.deployment.ModuleDeployer : Deploying module: ping-1.3
     [java] Oct-23-07 11:36:11.925 : INFO  : main                 :

g.apache.axis2.deployment.ModuleDeployer : Deploying module: script-1.3
     [java] Oct-23-07 11:36:11.949 : INFO  : main                 :
g.apache.axis2.deployment.ModuleDeployer : Deploying module: addressing-1.3 
     [java] Oct-23-07 11:36:11.960 : INFO  : main                 :
g.apache.axis2.deployment.ModuleDeployer : Deploying module: soapmonitor-1.3
     [java] Oct-23-07 11:36:11.971 : INFO  : main                 :

g.apache.axis2.deployment.ModuleDeployer : Deploying module:
metadataExchange-1.3
     [java] Oct-23-07 11:36:12.010 : INFO  : main                 :
org.apache.axis2.scripting.ScriptModule : script module activated 
     [java] Oct-23-07 11:36:12.189 : INFO  : main                 :
.apache.axis2.deployment.ServiceDeployer : Deploying Web service:
version.aar


The issue that I am having is that once axis is deployed, about the only 
things I can get to come back are the following

>>From the request (http://BLAHBLASH/axis2/services)
        <soapenv:Reason
xmlns:soapenv=" http://www.w3.org/2003/05/soap-envelope">
        <soapenv:Text xml:lang="en-US">The service cannot be found for the
endpoint reference (EPR) /axis2/services</soapenv:Text>
        </soapenv:Reason> 

It looks like things are close to "working" and that I am just missing
something.  Can anyone help shed any light on this?





Also, not sure if this helps, but I also get the following when I try to 
just access the context url

>>From the request (http://BLAHBLASH/axis2/)
HTTP Status 404 - /axis2/

----------------------------------------------------------------------------

----
        type Status report
        message /axis2/
        description The requested resource (/axis2/) is not available.

----------------------------------------------------------------------------

----
        Apache Tomcat/5.5.17

And a NPE from the console of the server of
     [java] java.lang.NullPointerException
     [java]     at
org.apache.catalina.core.StandardHostValve.custom(StandardHostValve.java
:363
)
     [java]     at
org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:284
)
     [java]     at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:136
)
     [java]     at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105
)
     [java]     at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:107)
     [java]     at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
     [java]     at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
     [java]     at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processC
onnection(Http11BaseProtocol.java:664)
     [java]     at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.jav
a:527)
     [java]     at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWo
rkerThread.java:80)
     [java]     at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav

a:684)
     [java]     at java.lang.Thread.run(Thread.java:595)





James Maes
Software Architect
Materialogic
PH: 800-333-7144
PH: 314-997-4342 Ext. 3422
FX: 314-997-7814


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message