axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ajith Ranabahu" <ajith.ranab...@gmail.com>
Subject Re: [Axis2] required jdk level
Date Thu, 20 Sep 2007 18:23:20 GMT
hi,
is the use of JAX-WS a requirement ? You can use Axis2 without JAX-WS
with JDK 1.4 without a problem . JAX-WS spec itself is defined on JDK
1.5 and hence there is no choice !

Ajith

On 9/20/07, Gennady Shumakher <Gennady@backflipsoftware.com> wrote:
> BTW, if you are looking for convertion between AXIOM and SAAJ try to use
> org.apache.axis2.saaj.util.SAAJUtil (it is jdk 1.4 compatible).
>
> Gennady
>
> -----Original Message-----
> From: Gennady Shumakher [mailto:Gennady@backflipsoftware.com]
> Sent: Thursday, September 20, 2007 17:35
> To: axis-user@ws.apache.org
> Subject: RE: [Axis2] required jdk level
>
> I had the same problem. Please look at
> http://marc.info/?l=axis-user&m=119012132524961&w=2
> The bottom line is axis2-jaxws where the mentioned package is located is
> jdk 1.5 dependant.
>
> Gennady
>
> -----Original Message-----
> From: ROSSILLE Samuel [mailto:samuel.rossille@cgi.com]
> Sent: Thursday, September 20, 2007 17:30
> To: axis-user@ws.apache.org
> Subject: [Axis2] required jdk level
>
> Hi
>
> I'm working on web services for CGI.
> We intend to use Axis2-1.3 as our web services stack. However, I'm
> having trouble with the following issue: I've read in the system
> requirement section on the download page, that all we need to use this
> version of Axis is the JDK 1.4. I've downloaded the standard binary
> distribution, and when I try to use the SAAJConverter, I get the
> following error at compile time:
>
> | cannot access org.apache.axis2.jaxws.message.util.SAAJConverter
> | bad class file:
> D:\users\samuel.rossille\webservices\download\axis2-1.3\lib\axis2-jaxws-
> 1.3.jar(org/apache/axis2/jaxws/message/util/SAAJConverter.class)
> | class file has wrong version 49.0, should be 48.0
>
> on this line
>
> | import org.apache.axis2.jaxws.message.util.SAAJConverter;
>
> I looked at the source code and found out that the actual source level
> of this class was java 1.5. Do you use a retro-translator tool ?  Is
> there a way to use these classes? I've been looking for documentation
> about this topic, but I've found nothing so far. Any help would be most
> welcome.
>
> Regards,
>
> Samuel Rossille
> CGI
> www.cgi.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Ajith Ranabahu

Reading, after a certain age, diverts the mind too much from its
creative pursuits. Any man who reads too much and uses his own brain
too little falls into lazy habits of thinking - Albert Einstein

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message