axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thilina Gunarathne" <cset...@gmail.com>
Subject Re: Java 1.4.x compatibilty
Date Thu, 27 Sep 2007 14:26:50 GMT
While I might not be the best person to comment on this, I got the
list by looking at the following section of the pom.xml[1] file. This
part was much more straight forward in maven1 (Oh... I really miss the
maven1 build).

<profile>
			<id>java15</id>
			<activation>
				<jdk>1.5</jdk>
			</activation>
			<modules>
				<module>modules/jaxbri</module>
				<module>modules/metadata</module>
				<module>modules/saaj-api</module>
				<module>modules/saaj</module>
                <module>modules/jws-api</module>
				<module>modules/jaxws-api</module>
				<module>modules/jaxws</module>
				<module>modules/clustering</module>
			</modules>

SAAJ new version 1.3 [2] introduced this dependency on JDK 1.5.. AFAIK
Axis2 does not ship jaxp, which is necessary for SAAJ to run on jdk
1.4..

But to my surprise I see the compile and source target set to jdk 1.3
in the SAAJ pom.xml... Must be a mistake...

thanks,
Thilina
[1]http://svn.apache.org/repos/asf/webservices/axis2/trunk/java/pom.xml
[2]https://saaj.dev.java.net/overview.html

On 9/27/07, Gennady Shumakher <Gennady@backflipsoftware.com> wrote:
> I was able to work with axis2 saaj and saaj-api with JDK 1.4. Futhermore
> I do not see any JDK 1.5 dependecy explicitly defined in poms of these
> modules.
>
> Could you elaborate on saaj jdk 1.5 dependency?
>
> Thanks,
> Gennady
>
> -----Original Message-----
> From: Thilina Gunarathne [mailto:csethil@gmail.com]
> Sent: Thursday, September 27, 2007 07:45
> To: axis-user@ws.apache.org; shalab.goel@oracle.com
> Subject: Re: Java 1.4.x compatibilty
>
> > Is it possible to run this client in the Java SDK 1.4.x environment?
> yes.
> > Previously, I believe there have been discussions on this forum that
> only 1.5 is >supported.
> Axis2 has few modules which depend on JDK1.5... But they don't get in
> your way unless you want to do something really specific like using
> JAXWS, JAXBRI etc.
>
> > 1) Is backward compatibility with older versions of Java 2 SDK being
> considered >for newer releases of Axis 2?
> According to the discussions that happened on the mailing list lately,
> most likely Axis2 will maintain compatibility with JDK 1.4 in the coming
> releases too.
> > 2) Is there a workaround that can be tried for Axis2 1.2?
> As I said above, it depends on what you want to do.. Almost all the
> normal Axis2 usages will run on jdk1.4..
>
> Following are the current list of features that depend on JDK 1.5.
> jaxbri, metadata,saaj-api,saaj,jws-api,jaxws-api,jaxws,clustering.
>
> thanks,
> Thilina
> >
> > Thanks
> > Shalab Goel
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-user-help@ws.apache.org
> >
> >
>
>
> --
> Thilina Gunarathne  - http://thilinag.blogspot.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Thilina Gunarathne  - http://thilinag.blogspot.com

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message