axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pantvaidya, Vishwajit" <vpant...@selectica.com>
Subject RE: [Axis2]wsdl2java with xmlbeans creates interface with xmlbeans.XmlString instead of java.lang.String
Date Thu, 27 Sep 2007 21:54:50 GMT
This is still not working for me in axis2 (it worked in axis1)

With "-d xmlbeans -uw" - the generated methods have org.apache.xmlbeans.XmlString instead
of java.lang.String for a string parameter
With "-d adb" (it does not let me specify "-uw") - generated methods have complex types (since
it does not let me specify unwrapping here thru' the -uw option)

How can I run wsdl2java so that the resultant web service interface methods use java.lang.String
instead of xmlbeans.XmlString?



________________________________
From: Pantvaidya, Vishwajit [mailto:vpantvai@selectica.com]
Sent: Wednesday, August 22, 2007 9:19 PM
To: axis-user@ws.apache.org
Subject: RE: [Axis2]wsdl2java with xmlbeans creates interface with xmlbeans.XmlString instead
of java.lang.String

Tried scomp with xmlbeans 2.2.0 (same version as bundled with axis2) - it gives error "error:
invalid.document.type: Document is not a wsdl file".

But coming back to original problem - the wsdl used to process fine with axis1 resulting in
interface with parameters of java types. Hasn't that been retained in axis2?

Tried wsdl2java with ADB to see if that gives me what I want. That also completed fine - but
resulting classes had all complex type params with generated types. So I tried the -uw option
- hoping it will unwrap those. But now I get error

org.apache.axis2.wsdl.codegen.CodeGenerationException: Unsupported Schema format for unwrapping!
found unknown type but expected Element

org.apache.axis2.wsdl.codegen.extension.SchemaUnwrapperExtension.processXMLSchemaSequence(SchemaUnwrapperExtension.java:370),
org.apache.axis2.wsdl.codegen.extension.SchemaUnwrapperExtension.handleAllCasesOfComplexTypes(SchemaUnwrapperExtension.java:198),
org.apache.axis2.wsdl.codegen.extension.SchemaUnwrapperExtension.walkSchema(SchemaUnwrapperExtension.java:143),
org.apache.axis2.wsdl.codegen.extension.SchemaUnwrapperExtension.engage(SchemaUnwrapperExtension.java:94),
org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(CodeGenerationEngine.java:218)

Any idea what this is about? Is -uw option the right one? What is difference between that
and -u? It is not very clear from the wsdl2java reference.


- Vish.
________________________________
From: Amila Suriarachchi [mailto:amilasuriarachchi@gmail.com]
Sent: Wednesday, August 22, 2007 8:56 PM
To: axis-user@ws.apache.org
Subject: Re: [Axis2]wsdl2java with xmlbeans creates interface with xmlbeans.XmlString instead
of java.lang.String

can you generate the code using xmlbeans scomp command and see what is the type?
anyway I think XmlString contanins a string inside it.

Amila.
On 8/23/07, Pantvaidya, Vishwajit <vpantvai@selectica.com<mailto:vpantvai@selectica.com>>
wrote:

I think I saw someone with same problem but cannot locate that message. My axis2 1.3 wsdl2java
with xmlbeans is completing successfully. But the generated interface has methods with parameters
of type xmlbeans.XmlString instead of java.lang.String. My expectation was it would map primitives
to java datatypes and create xmlbeans for complex types. Is this not the case? Do I need to
switch to ADB to get params with java types?



--
Amila Suriarachchi,
WSO2 Inc.

Mime
View raw message