axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lahiru Sandakith" <sandak...@gmail.com>
Subject Re: Loading JAR Files
Date Wed, 05 Sep 2007 02:53:21 GMT
Hi Jeff,

Normally when we create the service archive using the Axis2 Eclipse Service
Archive Creation Plugin we have to include the 3rd party jars at Page 4 [1],
and it will put that into the archive lib at the archive creation time then
axis2 class loading will handle the rest when we deploy that.

Thanks

Lahiru

[1] http://ws.apache.org/axis2/tools/1_3/eclipse/servicearchiver-plugin.html
**

On 9/5/07, Jeff Wang <jeffrey.wang@apple.com> wrote:
>
> Hello,
>
> I am having trouble loading JAR files in my AAR.  I put all the
> required JAR files in the WEB-INF/lib directory of the AAR.  I am
> using the Eclipse plug in to create the AAR.  However, when I run the
> web service, it cannot load the classes in my jar file.  I've had to
> resort to putting it in the lib directory or services/lib dir of the
> main axis2.war to be accessible.  Do I need to configure something to
> get these jars to load within my aar file??  I'm using axis2, version
> 1.3.
>
> thanks
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


-- 
Thanks
Lahiru Sandakith

http://sandakith.wordpress.com/
GPG Key Fingerprint : 8CD8 68E0 4CBC 75CB 25BC  1AB1 FE5E 7464 1F01 9A0F

Mime
View raw message