axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorge Fernandez <informaticu007-...@yahoo.es>
Subject MTOM problems
Date Sat, 01 Sep 2007 09:47:22 GMT
Hi all,

I'm having some problems in axis2 1.3 with MTOM attachments. When receiving message included
in attached file message2 there is no problem but my client has this exception when receiving
message included in attached file message1:

org.apache.axis2.AxisFault: Referenced Attachment not found in the MIME Message. ContentID:1.urn:uuid:0549F3F826EC3041861188639371827@apache.org
    at org.apache.axis2.AxisFault.makeFault(AxisFault.java:417)
    at client.Medici_LinkStub.fromOM(Medici_LinkStub.java:50213)
    at client.Medici_LinkStub.getSignalData(Medici_LinkStub.java:6500)
    at client.ClientUtilities.getSignalDataTest(ClientUtilities.java:600)
    at client.Client.main(Client.java:172)
Caused by: org.apache.axiom.om.OMException: Referenced Attachment not found in the MIME Message.
ContentID:1.urn:uuid:0549F3F826EC3041861188639371827@apache.org
    at org.apache.axiom.soap.impl.builder.MTOMStAXSOAPModelBuilder.getDataHandler(MTOMStAXSOAPModelBuilder.java:106)Closing
session...

    at client.Medici_LinkStub$ExtDataSegment$Factory.parse(Medici_LinkStub.java:34167)
    at client.Medici_LinkStub$ExtSignalData$Factory.parse(Medici_LinkStub.java:35862)
    at client.Medici_LinkStub$GetSignalDataResponse$Factory.parse(Medici_LinkStub.java:8777)
    at client.Medici_LinkStub.fromOM(Medici_LinkStub.java:49766)
    ... 3 more


Some days before I was working with Rampart engaged and it worked fine. Message2 sent 8 bytes
and Message1 sent 0 bytes but I think that the element wasn't null, so I think that may be
the problem: sending 0 bytes.

Thanks,

Jorge Fernández



       
---------------------------------

Sé un Mejor Amante del Cine
¿Quieres saber cómo? ¡Deja que otras personas te ayuden!.

Mime
View raw message