axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eran Chinthaka <chinth...@opensource.lk>
Subject Re: Axis2 client
Date Mon, 01 Oct 2007 01:21:15 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

What do you mean by "access endpoint first". When you send a request to
Axis2 egnine, it will always tries to find a service and operation
corresponding to that service.

In your request, you have only given the name of the service (Version)
and not the operation. So that is why Axis2 is claiming Operating not
found.

Please also read http://wso2.org/library/176.

Thanks,
Chinthaka

jerome.mariette wrote:
> Hello everybody,
> I'm using axis2 to develop a web service. I did it and it's working but I
> can't access to the Endpoint!
> When I deploye it, I can perfectly request the webservice and everything is
> fine, but if I want to access its EndPoint, I have the following:
>     The endpoint reference (EPR) for the Operation not found is
> /axis2/services/AvedService and the WSA Action = null
> So I tryed with the Version service which is already deployed in Axis with
> the following URL:
>     http://localhost:8080/axis2/services/Version
> and got the same problem !!
> 
> So I'm wondering if there is something specific to do to ba able to access
> the endpoint ?? I'd like to request my web service from Java Code so I do
> need to access the EndPoint first !
> 
> thanks for your help,
> Jerome

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHAEuKjON2uBzUhh8RAjMlAKCEhVgIu1QjyVbCgeMgF2tTTeERswCfTCWA
DRYtZ6spdWmsZnfrGdNXrxU=
=WgkC
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message