axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mr.knowledge" <mr.knowle...@gmx.de>
Subject Re: Axis Webservice question again
Date Thu, 20 Sep 2007 08:31:02 GMT
Hi Anne,

I still have questions. I tried to solve the problem. My definitions of 
messageTypes is in the berechnung.wsdl file and other wsdl files too. But 
how must I edit the namespace (e.g. tns) that it points to the wsdl file on 
my local computer because I test the service on http://localhost??? I tried 
it with <import but I'm not sure...

- tns must point to the local wsdl file berechnung.wsdl
messages like addiere response from addiererNS are in the (from Axis 
generated) AddiererWebService.wsdl even if I change

  xmlns:addiererNS="http://localhost:8080/axis/AddiererWebService.wsdl" this 
will not help.

How can I solve it? I attach all of the code in this mail if you want to 
look :-)

best regards in advance

alex


----- Original Message ----- 
From: "Anne Thomas Manes" <atmanes@gmail.com>
To: <axis-user@ws.apache.org>
Sent: Wednesday, September 19, 2007 2:01 PM
Subject: Re: Axis Webservice question again


> Alex,
>
> I don't have time this morning to do a thorough scan of the documents,
> but I do notice that your BPEL definition references serviceLinkTypes,
> messageTypes, and portTypes in the "tns" namespace, but none of these
> components are defined in that namespace. I suggest you search through
> the BPEL and check each "tns" reference, and figure out where the
> component is defined and change the namespace prefix accordingly.
>
> Anne
>
> On 9/19/07, mr.knowledge <mr.knowledge@gmx.de> wrote:
>>
>>
>> Thanks for the link. I post my question again in this forum as well. But 
>> if
>> someone has an idea (because I think the error is the namespace 
>> declaration)
>> please let me know.
>>
>> regards
>>
>> alex
>>
>> ----- Original Message -----
>> From: mr.knowledge
>> To: axis-user@ws.apache.org
>> Sent: Tuesday, September 18, 2007 4:30 PM
>> Subject: Axis Webservice question again
>>
>>
>> Hello,
>>
>> maybe my question is out of topic. I send it two times before but don't 
>> get
>> an answer until now. Please let me know if this is the wrong mailinglist.
>> But If someone can help me I would be very happy.
>>
>>
>>
>>
>> I have deployed some small example webservices in Axis and the services
>> work, i.e. if I click on
>>
>> http://localhost:8080/axis/services/AddiererWebService
>>
>> I get "Hi there, this is an AXIS service! Perhaps there will be a form 
>> for
>> invoking the service here..."
>>
>> I can also create the wsdl file throug attaching ?wsdl.
>>
>> But now my problem. I try to create a small BPEL example which uses my 2
>> Axis Webservices (called AddiererWebService and MultipliziererWebService)
>>
>> The WebService .class files are of course in the classes order. If I try 
>> to
>> deploy the .bpel and .wsdl file (which is included in this mail) I get 
>> the
>> following error message:
>>
>>
>>
>> Ouch, something went wrong while deploying the process. Here's the error 
>> I
>> got:
>>
>>
>> BPWSContainerProcessService: exception while compiling BPWS file: No
>> activity was found for the process. Perhaps the namespace is incorrect.
>>
>> I would be very happy If someone can help me which lines must be modified 
>> or
>> what should I do that this example works. I hope there is someone who can
>> help me. I suppose the error is in the namespace. Maybe the axis 
>> webservices
>> must be "adressed" in another way.
>>
>>
>>
>> best regards and thanks in advance
>>
>> alex
>>
>>  ________________________________
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-user-help@ws.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org 

Mime
View raw message