axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Hendrickson" <hendricks...@gmail.com>
Subject Re: [Axis2] New to Axis, having problems
Date Fri, 17 Aug 2007 06:09:43 GMT
Charitha,

Thank you very much for your kind help. I think I understand better now!

Regards,
Brian

On 8/16/07, Charitha Kankanamge <charitha@wso2.com> wrote:
>
> Hello Brian,
> I was able to invoke your service with ADB(Axis data binding, which is
> the default code generation mechanism). The generated client and service
> sources are attached here with. If you are using Eclipse as JAVA IDE,
> please create a new project from ant build file and run the client
> through eclipse. You should get the response back. I did the service and
> client generation using ADB since I'm not much familiar with xmlbeans.
>
> Let me know if you face any issues with the attached code.
>
> Also, I would recommend you to follow the Axis2 Quick start guide [1]
> and user guide [2] before trying out axis2 advanced user guide.
>
> [1] http://ws.apache.org/axis2/1_3/quickstartguide.html
> [2]http://ws.apache.org/axis2/1_3/userguide.html
>
> regards
> Charitha
>
> Brian Hendrickson wrote:
>
> > Hi Charitha,
> >
> > Thanks for offering to help. Here is my service.
> >
> > Brian
> >
> > On 8/16/07, *Charitha Kankanamge* < charitha@wso2.com
> > <mailto:charitha@wso2.com>> wrote:
> >
> >     Hello Brian,
> >     Will you be able to send me your service archive? I'll deploy it and
> >     write a client to invoke the service.
> >
> >     regards
> >     Charitha
> >
> >
> >     Brian Hendrickson wrote:
> >
> >     > Hello,
> >     >
> >     > I'm trying to create my first Axis2 application and I'm having a
> >     > problems. I'm creating a simple service that takes a string and
> >     echoes
> >     > it back to the client. I have generated service and client stubs
> >     from
> >     > a wsdl and filled them in as directed in the User's Guide, and the
> >     > service builds fine, but I can't build the client. I get the
> >     following
> >     > error:
> >     >
> >     >
> >     > compile.src:
> >     >     [javac] Compiling 1 source file to
> >     /home/brian/src/echo/build/classes
> >     >     [javac] /home/brian/src/echo/src/echo/Client.java:15: cannot
> >     find
> >     > symbol
> >     >     [javac] symbol  : method Echo(echo.Echo )
> >     >     [javac] location: class echo.EchoServiceStub
> >     >     [javac]         EchoResponse res = stub.Echo(req);
> >     >     [javac]                                   ^
> >     >     [javac] 1 error
> >     >
> >     > I am importing the stub that was generated for my client, but it
> >     still
> >     > can't find the method. Can please someone help the problem? I am
> >     very
> >     > new.
> >     >
> >     > Thanks
> >     > Brian
> >
> >
> >
> >
> >
> ---------------------------------------------------------------------
> >     To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >     <mailto:axis-user-unsubscribe@ws.apache.org>
> >     For additional commands, e-mail: axis-user-help@ws.apache.org
> >     <mailto:axis-user-help@ws.apache.org>
> >
> >
> >------------------------------------------------------------------------
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> >For additional commands, e-mail: axis-user-help@ws.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>

Mime
View raw message