axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <francois.m.bod...@accenture.com>
Subject error withy
Date Thu, 09 Aug 2007 07:06:38 GMT
Hi all,

 

I get an error when running a client of a web service using wss
security. 

The xml generated by axis after inserting the signature looks like this:

<soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XM

LSchema-instance">

<soapenv:Header>

<wsse:Security
xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wsse
curity-secext-1.0.xsd" soapenv:mustUnderstand="1"><wsse:UsernameToken

xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssec
urity-utility-1.0.xsd"
wsu:Id="UsernameToken-20467413"><wsse:Username>firma</wsse:Use

rname><wsse:Password
Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-t
oken-profile-1.0#PasswordDigest">G7Qdew4bVTsBwi4n5P9y1Lui+mQ=</w

sse:Password><wsse:Nonce>SaiZT7TAGZ+djpQpxp0asw==</wsse:Nonce><wsu:Creat
ed>2007-08-09T07:04:41.078Z</wsu:Created></wsse:UsernameToken></wsse:Sec
urity></soape

nv:Header><soapenv:Body><verificaResidencia
xmlns="http://www.accv.es/accv_map_gateway/ServiciosMap"><xmlMaps>&lt;ma
p-array&gt;

  &lt;map&gt;

    &lt;entry&gt;

      &lt;string&gt;DATAMAP_ISSPANIARD&lt;/string&gt;

      &lt;string&gt;true&lt;/string&gt;

    &lt;/entry&gt;

    &lt;entry&gt;

      &lt;string&gt;DATAMAP_TIPODOCUMENTACION&lt;/string&gt;

      &lt;string&gt;NIF&lt;/string&gt;

    &lt;/entry&gt;

    &lt;entry&gt;

      &lt;string&gt;DATAMAP_CONSENTIMIENTO&lt;/string&gt;

      &lt;string&gt;Si&lt;/string&gt;

    &lt;/entry&gt;

    &lt;entry&gt;

      &lt;string&gt;DATAMAP_NUMSOPORTE&lt;/string&gt;

      &lt;string&gt;&lt;/string&gt;

    &lt;/entry&gt;

    &lt;entry&gt;

      &lt;string&gt;DATAMAP_DOCID&lt;/string&gt;

      &lt;string&gt;99999999R&lt;/string&gt;

    &lt;/entry&gt;

  &lt;/map&gt;

&lt;/map-array&gt;</xmlMaps></verificaResidencia></soapenv:Body></soapen
v:Envelope></#document>

 

The problem is that this xml is not well formed (last tag is
</#document>) and I think that's why I receive the following error
message from the web service:

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soap:Body><soap:F
ault><faultcode>soap:Server</faultcode><faultstring>Unexpected character
combination '&lt;/' in

epilog (extra close tag?).

 at [row,col {unknown-source}]:
[27,85]</faultstring></soap:Fault></soap:Body></soap:Envelope>

 

The problem is that the xml is generated by axis and I only pass him as
an argument of the web service method (verificaResidencia) the xml tag
<xmlMap>.

 

Am I doing something wrong?

 

Thanks in Advance,

Francois



This message is for the designated recipient only and may contain privileged, proprietary,
or otherwise private information.  If you have received it in error, please notify the sender
immediately and delete the original.  Any other use of the email by you is prohibited.

Mime
View raw message