axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Sauyet <li...@sauyet.com>
Subject Re: axis2 -- minimum jars required for client??
Date Tue, 28 Aug 2007 12:45:20 GMT
Scott Sauyet wrote:
> I have the same question, and another similar one, which is what is the 
> minimum set of jar files needed to run WSDL2Java for an XMLBeans 
> binding.  Does anyone know how to find that list beyond just trial and 
> error?

Answering my own question, with the caveat that your mileage may vary 
significantly.  After a fair bit of trial and error, I found the 
following JAR files necessary and sufficient calling WSDL2Java directly 
with the options "-s" and "-d xmlbeans":

     axiom-api
     axis2-codegen
     axis2-kernel
     axis2-xmlbeans
     commons-logging
     neethi
     wsdl4j
     xbean
     XmlSchema


I use the same classpath for compiling the generated code.  To run test 
code against it, I need only these:

     axis2-kernel
     xbean

Again, your mileage may vary.  And if you're not using XMLBeans, there 
clearly would be changes to the lists.

   -- Scott


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message