axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charitha Kankanamge <chari...@wso2.com>
Subject Re: [Axis2] New to Axis, having problems
Date Fri, 17 Aug 2007 03:40:23 GMT
Hello Brian,
Will you be able to send me your service archive? I'll deploy it and 
write a client to invoke the service.

regards
Charitha


Brian Hendrickson wrote:

> Hello,
>
> I'm trying to create my first Axis2 application and I'm having a 
> problems. I'm creating a simple service that takes a string and echoes 
> it back to the client. I have generated service and client stubs from 
> a wsdl and filled them in as directed in the User's Guide, and the 
> service builds fine, but I can't build the client. I get the following 
> error:
>
>
> compile.src:
>     [javac] Compiling 1 source file to /home/brian/src/echo/build/classes
>     [javac] /home/brian/src/echo/src/echo/Client.java:15: cannot find 
> symbol
>     [javac] symbol  : method Echo(echo.Echo )
>     [javac] location: class echo.EchoServiceStub
>     [javac]         EchoResponse res = stub.Echo(req);
>     [javac]                                   ^
>     [javac] 1 error
>
> I am importing the stub that was generated for my client, but it still 
> can't find the method. Can please someone help the problem? I am very 
> new.
>
> Thanks
> Brian




---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message