axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "New AxisU" <newax...@gmail.com>
Subject Problem with Loading?
Date Thu, 02 Aug 2007 20:58:19 GMT
Hi,

I am stumped again and yet I think I am really close so ... I am trying to
write an axis2 client for my new sample axis2 service.
When I run the client I get:

a99-run.myclient:
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/axis2/client/Stub
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
        at java.security.SecureClassLoader.defineClass(
SecureClassLoader.java:124)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
        at org.mlbissonnette.quote.client.RandomQuoteClient.main(
RandomQuoteClient.java:35)



RandomQuoteWSStub.class exists in build directory

I get the same error message when I try run outside of ant usin g

java -jar myclient.jar

I'm using axis2  1.3 RC2.  Is this a classpath problem or did I not generate
the code correctly?

Any thought would be appreciated?

Mime
View raw message