axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "robert lazarski" <robertlazar...@gmail.com>
Subject Re: [Axis2] SOAPMonitorApplet port
Date Thu, 26 Jul 2007 13:04:07 GMT
I'm not a windows user, but you do have the netstat command that can
help you track your occupied ports. On linux it'd be 'netstat -ancp |
grep 5001' .

You can engage the module in either services.xml or axis2.xml - but
not both. engaging in axis2.xml make the module available for all
services, whereas alternatively engaging in the services,xml makes to
module available to just that service.

If all else fails, you could use tcpmon as an alternative.

HTH,
Robert

On 7/25/07, Jack Sprat <rexclaimer2@yahoo.com> wrote:
> Hi Robert.
>
> Thanks for trying to help.  This has me quite confused.
> The Tomcat console says that the server socket on the port specified in
> web.xml cannot be opened.  If I set port 3901 then the console says port
> 3901 cannot be opened.  Same for port 5001.
> The ports show as used by the javaw.exe process.
>
> My only other question on the SOAP monitor applet is where to set the module
> ref.  I have this set in the services.xml file.  This is the same as the
> logging module, with the instructions here:
> http://ws.apache.org/axis2/1_1/modules.html
> But the SOAP monitor page says to set the module reference in the axis2.xml
> file.  Which is right?
>
> Axis2 with Tomcat 5.5
>
> Thanks,
> T
>
>
> robert lazarski <robertlazarski@gmail.com> wrote:
>  When you set the port to 3901, does it still say cannot connect to
> 5001? Can you try RC2? I'll try to give this scenario a spin today.
>
> HTH,
> Robert
>
> On 7/24/07, Jack Sprat wrote:
> > I've tried ports 3901, 5001 and 5050. All gave the same result.
> >
> >
> > robert lazarski wrote:
> > Have you tried changing to another port in the web.xml?
> >
> > HTH,
> > Robert
> >
> > On 7/24/07, Jack Sprat wrote:
> > > I've followed the instructions for setting up the SOAP monitor applet
> > here:
> > > http://ws.apache.org/axis2/1_2/soapmonitor-module.html
> > >
> > > Whenever I start my server I get the following errors:
> > >
> > > 2007-07-24 18:18:20,468 ERROR SOAPMonitorService - Unable to open server
> > > socket using port: 5001
> > > 2007-07-24 18:18:20,484 ERROR SOAPMonitorService - Address already in
> use:
> > > JVM_Bind
> > >
> > > It does not seem to matter what port is used.
> > >
> > > What am I doing wrong?
> > >
> > > Thanks,
> > > T
> > >
>
>
>
>  ________________________________
> Sick sense of humor? Visit Yahoo! TV's Comedy with an Edge to see what's on,
> when.
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message