axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "keith chapman" <keithgchap...@gmail.com>
Subject Re: [Axis2] Problem using SOAP12 vs SOAP11?
Date Fri, 27 Jul 2007 08:59:11 GMT
Here are the details.
http://www.w3.org/TR/soap12-part2/#http-respbindprocess

Thanks,
Keith.

On 7/27/07, keith chapman <keithgchapman@gmail.com> wrote:
>
> Ho Jose,
>
> This is not a bug. The SOAP 1.2 specification mentions that we should send
> HTTP code 400 in a fault if the fault code is soap:Sender. This is the
> reason for getting 400 when using SOAP 1.2 and 500 when using SOAP 1.1.
>
> Thanks,
> Keith.
>
> On 7/27/07, Jose Luis Alba <josedevmail@yahoo.es> wrote:
> >
> > Hi,
> >
> > Recently I've been working on a test web service in Axis2 (1.3-RC1).
> > That service launchs checked exceptions but the behavior is different if I
> > use SOAP11 or SOAP12 from the client.
> >
> > When I use SOAP12 all responses from my exceptions are and AxisFault
> > with error 400: Bad request. (That's done in MessageContextBuilder ->
> > createFaultEnvelope -> getSenderFaultCode)
> >
> > When I use SOAP11 from the client I receive and AxisFault but this time
> > with an status error 500 and with the message of my exception. That's is
> > what I excepted!
> >
> > Why this behavior?
> > There's a bug in the SOAP12?
> > I'm missing something?
> >
> > Thanks,
> >
> > Jose
> >
> > ------------------------------
> >
> > Sé un Mejor Amante del Cine
> > ¿Quieres saber cómo? ¡Deja que otras personas te ayuden!
> > <http://us.rd.yahoo.com/mail/es/tagline/beabetter/*http://advision.webevents.yahoo.com/reto/entretenimiento.html>
> > .
> >
> >
>
>
> --
> Keith Chapman
> WSO2 Inc.
> Oxygen for Web Services Developers.
> http://wso2.org/




-- 
Keith Chapman
WSO2 Inc.
Oxygen for Web Services Developers.
http://wso2.org/

Mime
View raw message