axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From p.casen...@almerys.com
Subject Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project
Date Wed, 01 Aug 2007 06:56:45 GMT
I have logged the JIRA:
https://issues.apache.org/jira/browse/AXIS2-3043

Thanks,
Pierre




"Anne Thomas Manes" <atmanes@gmail.com> 
31/07/2007 19:34
Veuillez répondre à
axis-user@ws.apache.org


A
axis-user@ws.apache.org
cc

Objet
Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project






Please log a JIRA.

On 7/31/07, p.casenove@almerys.com <p.casenove@almerys.com > wrote:

I have downloaded the latest jaxb distrib from sun website and the 
wsdl2java operation is completed successfully using the xjc.bat script 
file provided by Sun. 
But it still fails using Axis2. 
Do I have to log a JIRA with the wsdl/xsd causing the issue? 

Pierre 




p.casenove@almerys.com 
31/07/2007 14:27 


Veuillez répondre à
axis-user@ws.apache.org


A
axis-user@ws.apache.org 
cc

Objet
Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project









Hi, 
I'm still trying to get the generated code with jaxbri without success. 
If I use one single wsdl file without imports, the generation is ok, but 
as soon as I introduce imports, it crashes with the exception: 
  [java] Exception in thread "main" 
org.apache.axis2.wsdl.codegen.CodeGenerationException: 
org.apache.axis2.wsdl.codegen.CodeGenerationException: 
org.apache.axis2.wsdl.databinding.UnmatchedTypeException: No type was 
mapped to the name TEST_REQUETE with namespace 
http://www.almerys.com/services/FSAServiceTest/xsd 
    [java] at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(
CodeGenerationEngine.java:265) 
    [java] at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:35) 
    [java] at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:24) 
    [java] Caused by: 
org.apache.axis2.wsdl.codegen.CodeGenerationException: 
org.apache.axis2.wsdl.databinding.UnmatchedTypeException:No type was 
mapped to the name TEST_REQUETE with namespace 
http://www.almerys.com/services/FSAServiceTest/xsd 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.emitSkeleton(
AxisServiceBasedMultiLanguageEmitter.java:1363 ) 
    [java] at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(
CodeGenerationEngine.java:247) 
    [java] ... 2 more 
    [java] Caused by: 
org.apache.axis2.wsdl.databinding.UnmatchedTypeException: No type was 
mapped to the name TEST_REQUETE with namespace 
http://www.almerys.com/services/FSAServiceTest/xsd 
    [java] at 
org.apache.axis2.wsdl.databinding.TypeMappingAdapter.getTypeMappingName(
TypeMappingAdapter.java:82 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.getInputParamElement(
AxisServiceBasedMultiLanguageEmitter.java:2823 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.getInputElement(
AxisServiceBasedMultiLanguageEmitter.java:2623 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.generateMethodElement(
AxisServiceBasedMultiLanguageEmitter.java:2191 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.loadOperations(
AxisServiceBasedMultiLanguageEmitter.java:2117 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.createDOMDocumentForSkeleton(
AxisServiceBasedMultiLanguageEmitter.java:2033 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.writeSkeleton(
AxisServiceBasedMultiLanguageEmitter.java:1964 ) 
    [java] at 
org.apache.axis2.wsdl.codegen.emitter.AxisServiceBasedMultiLanguageEmitter.emitSkeleton(
AxisServiceBasedMultiLanguageEmitter.java:1320 ) 
    [java] ... 3 more 
    [java] Java Result: 1 

I really don't see where I'm doing wrong. 

Thanks for the help 

Pierre 



p.casenove@almerys.com 
31/07/2007 10:28 

Veuillez répondre à
axis-user@ws.apache.org



A
axis-user@ws.apache.org 
cc

Objet
Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project











Hi, 
Does anybody have an idea of the source of the problem? My wsdl seems to 
be valid (only jaxb generation fails, xmlbeans and adb are OK). I really 
don't see the issue. 

Thanks, 
Pierre 

p.casenove@almerys.com 
30/07/2007 14:11 

Veuillez répondre à
axis-user@ws.apache.org



A
axis-user@ws.apache.org 
cc

Objet
Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project













Hi, 
thanks for the answer. 
I copied an erroneous Exception in my initial email, here is the correct 
one: 

[java] Exception in thread "main" 
org.apache.axis2.wsdl.codegen.CodeGenerationException: 
org.apache.axis2.wsdl.codegen.CodeGenerationException: 
org.apache.axis2.wsdl.databinding.UnmatchedTypeException: No type was 
mapped to the name TEST_REQUETE with namespace 
http://www.almerys.com/services/FSAServiceTest/xsd 
  [java] at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.generate(
CodeGenerationEngine.java:265) 

There can be errors in my wsdl as it was in rpc/lit style and I converted 
it to document/literal. I'll correct the issues. 

Pierre 
"Anne Thomas Manes" <atmanes@gmail.com> 
30/07/2007 13:44 

Veuillez répondre à
axis-user@ws.apache.org



A
axis-user@ws.apache.org 
cc

Objet
Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project














Do you have any idea where the referenced namespace comes from? " 
http://www.tests.com/services/ServiceTest/xsd "? 

Is that specified in a configuration file somewhere? 

A few minor issues with your WSDL: 

In your schema, you must declare both imports before declaring any 
elements. 

And in the binding, you must remove the namespace attributes from the 
<soap:body> declarations. (The namespace attribute must NOT be used when 
using style="document". It should be used only when using style="rpc".) 
When using document/literal, a <soap:body> declaration should look like 
this: 

         <soap:body use="literal" /> 

Anne


On 7/30/07, p.casenove@almerys.com <p.casenove@almerys.com> wrote: 

Hi, 
I've been updating to Axis2 1.3RC2 in order to try JAXB RI as the 
databinding. 
While my wsdl is correctly parsed and my code generated with adb and 
xmlbeans, I receive the exception with jaxb: 
[java] Exception in thread "main" 
org.apache.axis2.wsdl.codegen.CodeGenerationException: 
org.apache.axis2.wsdl.codegen.CodeGenerationException : 
org.apache.axis2.wsdl.databinding.UnmatchedTypeException : No type was 
mapped to the name TEST_REQUETE with namespace 
http://www.tests.com/services/ServiceTest/xsd 


Here is the wsdl: 

<?xml version= "1.0" encoding ="UTF-8"?> 
< wsdl:definitions 
    xmlns:soapenc= "http://schemas.xmlsoap.org/soap/encoding/ " 
    xmlns:tns=" http://www.almerys.com/services/FSAServiceTest" 
    xmlns:wsdl =" http://schemas.xmlsoap.org/wsdl/" 
    xmlns:wsdlsoap= "http://schemas.xmlsoap.org/wsdl/soap/ " 
    xmlns:xsd=" http://www.w3.org/2001/XMLSchema" 
    xmlns:xsi= " http://www.w3.org/2001/XMLSchema-instance " 
    targetNamespace= "http://www.almerys.com/services/FSAServiceTest " 
    xmlns:typeRequest=" 
http://www.almerys.com/services/FSAServiceTest/types/request" 
    xmlns:typeReponse =" 
http://www.almerys.com/services/FSAServiceTest/types/reponse" 
    xmlns:xsd1 =" http://www.almerys.com/services/FSAServiceTest/xsd "> 
    < wsdl:types> 
            < xsd:schema elementFormDefault="qualified" targetNamespace=" 
http://www.almerys.com/services/FSAServiceTest/xsd" xmlns= 
"http://www.w3.org/2001/XMLSchema " xmlns:wsdl =" 
http://schemas.xmlsoap.org/wsdl/ "> 
                    < xsd:import 
                            namespace= "
http://www.almerys.com/services/FSAServiceTest/types/request " 
                            schemaLocation= "TEST_REQ.xsd" /> 

                    < xsd:element name= "TEST_REQUETE" type=
"typeRequest:TEST_REQUETE_DETAIL" /> 
 
                    <xsd:import 
                            namespace=" 
http://www.almerys.com/services/FSAServiceTest/types/reponse" 
                            schemaLocation="TEST_REP.xsd" /> 
 
                    <xsd:element name="TEST_REPONSE" type=
"typeReponse:TEST_REPONSE_DETAIL" /> 
            </xsd:schema > 
</wsdl:types > 
 
    < wsdl:message name="getTestRequest" > 
            <wsdl:part name="TEST_REQUETE" element ="xsd1:TEST_REQUETE" /> 

    </wsdl:message> 

    <wsdl:message name= "getTestResponse"> 
            < wsdl:part name="TEST_REPONSE" element="xsd1:TEST_REPONSE" /> 

    </wsdl:message> 

    <wsdl:portType name ="Test"> 
            <wsdl:operation name= "getTest" parameterOrder="TEST_REQUETE" 
> 
                    < wsdl:input message="tns:getTestRequest" 
                            name="getTestRequest" /> 
                    < wsdl:output message="tns:getTestResponse" 
                            name="getTestResponse" /> 
            </ wsdl:operation> 
    </ wsdl:portType> 

    < wsdl:binding name="WebServiceTestSoapBinding" type="tns:Test" > 
            <wsdlsoap:binding style ="document" 
                    transport=" http://schemas.xmlsoap.org/soap/http" /> 
            <wsdl:operation name= "getTest"> 
                    < wsdlsoap:operation soapAction=" 
http://www.almerys.com/services/FSAServiceTest/getTest" style= "document" 
/> 
                    < wsdl:input name= "getTestRequest"> 
                            <wsdlsoap:body 
                                    namespace=" 
http://www.almerys.com/services/FSAServiceTest" 
                                    use ="literal" /> 
                    </wsdl:input> 
                    <wsdl:output name ="getTestResponse"> 
                            <wsdlsoap:body 
                                    namespace=" 
http://www.almerys.com/services/FSAServiceTest" 
                                    use ="literal" /> 
                    </wsdl:output> 
            </wsdl:operation> 
    </wsdl:binding > 


    <wsdl:service name="ServiceTest" > 
            <wsdl:port binding ="tns:WebServiceTestSoapBinding" 
                    name="ServiceTest" > 

                    <wsdlsoap:address 
                            location=" 
http://localhost:8080/fsa/services/ServiceTest" /> 
                    <wsdlsoap:address 
                            location=" 
http://localhost:8080/fsa/serverAuthent/ServiceTest" /> 
            </wsdl:port> 
    </wsdl:service> 

</ wsdl:definitions> 

Am I making an error in the wsdl or is it a bug from the code generator? 

Thanks, 

Pierre 
"Davanum Srinivas" <davanum@gmail.com > 
27/07/2007 03:07 

Veuillez répondre à
axis-user@ws.apache.org 



A
axis-user@ws.apache.org 
cc

Objet
Re: [1.3-RC2] Build JAX-WS server from wsdl in maven2 project













Farrukh,

You can use WSDLJava.bat/sh from the command line (either nightly or
1.3 RC2) with "-d jaxbri" to select the JAXB RI as the data binding. 

-- dims

On 7/26/07, Farrukh S. Najmi <farrukh@wellfleetsoftware.com > wrote:
> Davanum Srinivas wrote:
> > Farrukh,
> >
> > I just updated the ant task and maven2 mojo this morning :) docs are
> > still in the works. will try to post something as soon as possible. 
> Sounds good. Do you advice building against latest svn bits?
>
> Also, is it possible to use JAXB RI from Sun with Axis 2?
>
> Thanks again for your help.
>
> --
> Regards, 
> Farrukh
>
> Web: http://www.wellfleetsoftware.com 
>
>
>
> --------------------------------------------------------------------- 
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org 
> For additional commands, e-mail: axis-user-help@ws.apache.org 
>
>


-- 
Davanum Srinivas :: http://davanum.wordpress.com 

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org 
For additional commands, e-mail: axis-user-help@ws.apache.org 


Mime
View raw message