axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Michael.Da...@servicecanada.gc.ca>
Subject wss4j and axis2?
Date Mon, 09 Jul 2007 21:09:50 GMT
Hi,

I've been digging around the source code of wss4j (the WS-Security library used by Rampart),
and there's something very fundamental I don't understand.

As far as I know, I've got the most recent versions of these (axis2 1.2, wss4j 1.5.2). The
strange thing is, wss4j seems to use the older axis 1 libraries, with package names like org.apache.axis.*,
whereas axis2 has package names like org.apache.axis2.*.

I would expect to get a lot of ClassNotFound exceptions, but it seems to work fine. Is there
some strange trickery going on, or am I just confused?

Thanks
Michael Davis

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message