axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ingrid Alongi <ingridalo...@yahoo.com>
Subject Axis2/Rampart Dispatch Errors
Date Fri, 27 Jul 2007 23:23:47 GMT


Hi All,


We are currently trying to consume a Web Service that
requires a WS-Security token and have decided to use Axis2 and Rampart.


We set up and ran the sample code in the Axis2/Rampart  located here: 


http://wso2.org/library/240


 


The sample code works correctly.  However once we generate ADB stubs and load
the axis2.xml  we get the following
error:


 


org.apache.axis2.deployment.DeploymentException: The
"Dispatch" phase is not found on the global "InFlow" phase
of the axis2.xml file. Make sure the phase is within the axis2.xml file.


    at


org.apache.axis2.deployment.DeploymentEngine.loadRepository(DeploymentEngine


.java:141)


    at


org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(File


SystemConfigurator.java:114)


    at


org.apache.axis2.context.ConfigurationContextFactory.createConfigurationCont


ext(ConfigurationContextFactory.java:60)


    at


org.apache.axis2.context.ConfigurationContextFactory.createConfigurationCont


extFromFileSystem(ConfigurationContextFactory.java:174)


 


 


The axis2.xml obviously is not an issue as we are using the
exact same axis2.xml file as used by the rampart samples (which work with their
stub client/services).  


 


Does anyone have any advice in tracking down this issue?


Thanks,
ingrid




       
____________________________________________________________________________________
Yahoo! oneSearch: Finally, mobile search 
that gives answers, not web links. 
http://mobile.yahoo.com/mobileweb/onesearch?refer=1ONXIC

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org


Mime
View raw message